TRB140 email event reporting issue

Hi, I am not sure if I do something wrong here, I have set up smtp email account - it works, manual email sending works, and email tests do work too, but then when I create traps on event reporting the system is not sending emails. When I send the email by hand under the individual event reporting setup section the emails are sent out correctly, but the system is not processing any traps on its own, I have WebGUI trap, port state, topology, and reboot, but none of it works. For the sake of tests, I have set sms in place of email and it does process sms more or less, does not seem to pick up on all events however.

TRB140 with fresh firmware TRB1_R_00.07.04.4 → same behavior on the previous stable version.

The gateway is linked to RMS (not sure if this would affect it), I have as well set the box to write logs to file from RAM, with no change unfortunatelly.

Any idea why the system would miss reporting the events? Is there anything else I would need to set up to get this working?

Thank you, Tara


I have tried to replicate your issue with the 07.04.4 firmware, but was unable to. All emails were received. I was using gmail:


Could you please access the command line of the device as described here, and execute the following command to view logs in real-time:

  • logread -f

Then, without closing the command line, try making changes to the device via WebUI and look at the logs produced. Are there any logs relevant to emails?

Also, when making changes via WebUI, make sure you press Save & Apply. The changes to the configurations are not done until you save them.

Kind Regards,

Sorted, this looks like a problem with Google (or email script), for some reason it does not log in when triggered by the event system, only by hand trigger. Once I have used Outlook everything works with no problem. It would be handy to have debug on sendmail (maybe there is one, I had no time to read all the manuals yet). Thnx for helping


I was able to receive emails when the events where triggered using gmail. Can you try copying my email settings in System → Administration → Recipients? Try enabling secure connection, set SMTP port to 587, etc.

Kind Regards,


It seems like you have done the basic setup for SMTP email account and tested the manual email sending, which works fine. However, the automatic event reporting via email is not functioning as expected, and you’ve also noticed that SMS event reporting is not consistent. Here are some troubleshooting steps you can follow to identify the issue:

Check Trap Settings: Verify that the trap settings for email and SMS are correctly configured. Ensure that the email address you want to receive the event notifications is entered correctly, and there are no typos or errors.

Event Filtering: Review the event filtering settings to make sure that the events you want to be reported are not being filtered out or ignored. It’s possible that certain events are not triggering the traps.

Log Analysis: Check the system logs to see if there are any error messages or warnings related to the event reporting. The logs may provide valuable information about why the system is not sending email traps.

Firmware and Software Updates: As you mentioned using a specific firmware version, check for any firmware updates or patches that may address known issues related to event reporting.

RMS Integration: Since the gateway is linked to RMS (Remote Management System), there might be some configurations in RMS that could impact event reporting. Verify the RMS settings and ensure they align with your desired event reporting configurations.

SMTP Server Requirements: Confirm that the SMTP server you are using for email notifications doesn’t have any restrictions or limitations that could prevent the automated emails from being sent. Some SMTP servers may require additional authentication or have sending limits.

Firewall and Network Configuration: Check the gateway’s network settings and firewall configurations to ensure that it can reach the SMTP server and that there are no network-related issues blocking the outgoing email traffic.

I hope the information helps you.

This topic was automatically closed after 15 days. New replies are no longer allowed.