TRB140 does not forward SMS

Hello, we use the product to receive SMS and forward them via email, everything works correctly with the Mobile connection, but if we also connect the network cable to manage the device, it does not forward the SMS, could you kindly give us some suggestions?


Could you please clarify if you are connecting the network cable to LAN or WAN port? When you connect the cable, is mobile connection still present?

If you connected a WAN cable, it is possible that the device cannot reach the email server over the wired WAN due to some restrictions in the network, like firewall.

Also, could you please try to navigate to Network → Interfaces → Edit LAN interface and add custom DNS servers: and

Also, make sure that you are running the latest firmware version. For TRB140, it can downloaded from here and uploaded in System → Firmware → Update firmware. Make sure to disable the ‘keep settings’ option to avoid any potential migration issues.

Kind Regards,


Thanks for the reply.
The device only has one ethernet port (no WAN) and we connect a cable to our LAN.
From the home page we have evidence that both the LAN and Mobile connections are working correctly.
We also set the DNS as indicated even if there is a dhcp server behind it.
I also confirm that I am on the latest firmware version TRB1_R_00.07.04.5

Unfortunately it doesn’t forward text messages unless unplug the network cable.

Thank you


Sorry, missed that it was TRB140.

I am not sure how a LAN cable could cause SMS to Email service to fail in this case. Are you sure its the cable? Or maybe the issue appeared after you have updated the device?

Could you please try resetting the device to defaults and try reconfiguring the SMS to Email service again? If you want, you can download a backup file before resetting the device so that you could upload it after the test.

Kind Regards,


we reconfigured the device and the problem was resolved.
Thanks for the advice.


1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.