TRB-142 AT SMS Commands

We have a legacy RTU that can send SMS messages and we’ve tried to use the TRB-142 to do this.
Created an RS232 profile, set the baud rate.

The TRB-142 isn’t following the standard SMS command set?

Tx: AT\r\n
Rx: OK\r\n
Tx: AT+CMGF=1\r\n
Rx: OK\r\n
Tx: AT+CMGS=“+6421xxxxxx”\r\n
** after sending the number we receive nothing ?? should get the “>” prompt for text ??
BUT if we:
Tx: Hello World\r\n ** the the TRB-142 replies
Rx: >
Rx: +CMGS:247\r\n
Rx OK\r\n

Is there a bug with the SMS command or another setting we need to use?
Latest firmware installed: TRB1_R_00.07.06.4 | 2024.01.18
Used the same terminal as example below:
https://wiki.teltonika-networks.com/view/SMS_sending_command

This topic was automatically closed after 15 days. New replies are no longer allowed.