Switch TSW202 - unable to access SSH (port not open)

Hello everyone.

I have the TSW202:

  • Firmware version TSW2_R_00.01.02
  • Kernel version 5.10.142

For some reason I cannot access SSH even if it’s enabled in the GUI. I’ve tried turning the setting on and off, restarting the device, tried enabling the SSH PAM option, but without any luck:

SSH:

$ ssh root@192.168.1.2
ssh: connect to host 192.168.1.2 port 22: Connection timed out

Telnet:

$ telnet 192.168.1.2 22
Trying 192.168.1.2...

Nmap:

$ nmap 192.168.1.2
Starting Nmap 7.80 ( https://nmap.org ) at 2024-03-25 20:20 CET
mass_dns: warning: Unable to determine any DNS servers. Reverse DNS is disabled. Try using --system-dns or specify valid servers with --dns-servers
Nmap scan report for 192.168.1.2
Host is up (0.0010s latency).
Not shown: 995 filtered ports
PORT    STATE  SERVICE
53/tcp  closed domain
80/tcp  closed http
443/tcp open   https
993/tcp closed imaps
995/tcp closed pop3s

Is there some setting I’ve missed? Maybe this is a bug?
Thanks.

Alright this is extremely embarrassing but the connection was blocked by my firewall.

I mistakenly assumed that connecting to port 22 was allowed inside my LAN in general but there was only one exception to my other Teltonika device where SSH worked so I was wondering why I couldn’t connect to the switch.

Sorry, I’m dumb.