Special Characters in Email to SMS

Hello! I am using a RUT241 to read emails and send SMS. Everything is working as expected, but the device does not seem to be able to read special characters, such as à é ã ç, etc. Whenever an email is received with these characters, they are ignored. If I copy the same text with the same special characters into the “Send Message” feature, it sends those characters without issue; the only problem is when reading emails with those characters. Is there some sort of setting I am missing? Thank you

Hello,

I have tried to replicate your issue on FW 7.04.4, but was unable to. The email contents were properly sent over SMS:

Ensure that you are running the latest firmware version. If the issue persists, try restoring the device to factory settings and try again.

Kind Regards,

Hello!

Using the latest firmware version, the Email to SMS feature simply stops working. Using the exact same configurations for the Email to SMS in the versions 7.04.05, 7.04.03, 7.04.02, and 7.04.01, the RUT doesn’t seem to access the email account. The latest firmware I can get to work is version 7.03.4. After every firmware change, I have done a factory reset.

Using the Send Messages feature I can send SMS in any firmware version, so I believe the problem lies in the reading the email part.

These are the configurations I am using:

In the latest firmwares, are there additional settings I need to change besides in the Mobile Utilities\SMS Gateway\Email to SMS?

Thank you for your time and attention.

Hello,

Apologies for the late reply.

Could you share your other configurations?

Have you tried a different email for testing purposes?

Please, access the device via command line (instructions here) and execute the following command to view logs in real-time:

logread -f

Then, try sending an email. Are there any logs related to emails or SMS? If so, please, post them here.

Also, please note that when accessing the command line of the device, you need to use ‘root’ as the username. The password will be the same password that you use for WebUI access.

Kind Regards,

Hello! Thank your for the reply.

What other configurations would you like me to share? I have tried with both a Gmail and an Outlook account. When accessing the logs, these messages were generated:

Mon Aug 21 10:06:00 2023 cron.err crond[7341]: USER root pid 13761 cmd lua /usr/bin/email_to_sms read
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: TEST text
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: TEST text
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: Message too big (51918 bytes). Max allowed size is 20480 bytes
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: TEST text
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: Message too big (52419 bytes). Max allowed size is 20480 bytes
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: TEST text
Mon Aug 21 10:06:03 2023 daemon.err email_to_sms: Message too big (55379 bytes). Max allowed size is 20480 bytes
Mon Aug 21 10:06:04 2023 daemon.err email_to_sms: TEST text
Mon Aug 21 10:06:04 2023 daemon.err email_to_sms: Message too big (54938 bytes). Max allowed size is 20480 bytes
Mon Aug 21 10:06:04 2023 daemon.err email_to_sms: TEST text
Mon Aug 21 10:06:04 2023 daemon.err email_to_sms: Message too big (53359 bytes). Max allowed size is 20480 bytes
Mon Aug 21 10:06:05 2023 daemon.err email_to_sms: TEST text Test final
Mon Aug 21 10:06:05 2023 daemon.err email_to_sms: Message too big (50158 bytes). Max allowed size is 20480 bytes
Mon Aug 21 10:06:05 2023 daemon.err email_to_sms: TEST text Apenas texto simples
Mon Aug 21 10:06:05 2023 daemon.err email_to_sms: Message too big (44754 bytes). Max allowed size is 20480 bytes

Since the messages were related to the size of the email, I changed the settings of the email from HTML to Plain Text. The first 5 emails are still the previous ones in HTML, the penultimate email was sent as “Test à ç ê ã final” but the message in the CLI only shows “Test final”. The last email did not contain any special characters and appears in full in the CLI, but it still give the same size error.

Thank you for your time and attention.

Kind Regards,

Hello,

It appears that you currently have an active case in the HelpDesk, along with a testing firmware. The RnD is also aware of your case. To address this issue, I recommend that you maintain your communication through the HelpDesk in order to proceed with the troubleshooting process.

Kind Regards,

Hello,

Indeed I do have an active case in the HelpDesk, however I opened this ticket before I was able to contact the HelpDesk, hence why I continued to answer here. Thank you for your help so far.

Kind Regards,

Hi,

how do u solve the Problems with the Special Characters?

kind regards

I solved the problem myself by installing another language “German”.
I changed the language in the web frontend.
I also change the SIM card, but I think that wasn’t the solution.

kind regards