Snmp on RUTX50 does not respond

the snmp processes are running.
snmp on rutx50 does not respond to requests. Neither v1, v2 nor v3.
config agent ‘general’
option ipfamily ‘ipv4’
option port ‘161’
option mibfile ‘/etc/snmp/RUTX50.mib’
option proto ‘udp’
option enabled ‘1’
option remoteAccess ‘1’
option v3mode ‘1’
option v1mode ‘1’
option v2cmode ‘1’

Whats wrong?

Further: Is it possible to install snmpwalk and snmpget on the rutx50?

On which interface are you trying to get snmp replies ? Lan ? Wan ? Other (VPN) ?
If it is on wan you must allow it explicitly: go to Services->SNMP and set “Enable remote access”.

For snmpget / snmpwalk / … use a ssh or cli console and install snmp-utils:

opkg update
opkg install snmp-utils



Thanks for your answer.

Source interface for snmp requests is BR-LAN. As I wrote, remote access is enabled.

In addition, despite installing the snmp-utils and then rebooting, I get the following error messages:

root@Teltonika-RUTX50:~# snmpwalk

Error loading shared library No such file or directory (needed by /usr/bin/snmpwalk)

root@Teltonika-RUTX50:~# snmpget

Error loading shared library No such file or directory (needed by /usr/bin/snmpget)


libnetsnmp appears to be miissing install it with opkg install libnetsnmp.
Which firmware version do you use ? The current version contains Maybe you can try an upgrade ?

This topic was automatically closed after 15 days. New replies are no longer allowed.