Setting up wireguard

Hi, Appreciate it anyone can assist with getting wireguard to work as a client.
FW ver RUT9xx_R_00.06.09.5
I setup the wireguard interface and peer, but when i use command ‘wg’ in CLI, nothing is showing up.
Below is an example from another attempt on another teltonika.

Is there anything else part from these 2 setting that i need to add?
Please let me know what information can I provide further for assistance.


Here are some additional screenshot of the config

Here are some additional screenshot of the config. (The forum only allow me to embed one picture at a time)


To begin, could you please clarify if there is a reason why you are using a legacy firmware version? If possible, I suggest you update to the latest firmware version as there were many bugfixes and improvements since then.

Secondly, make sure that allowed IPs are matched on both ends on the WireGuard tunnel. The IP address specified in the WireGuard configuration on RUT should be included in the list of allowed IPs on the other end, and vice versa.

Also, please check if you can reach the remote endpoint and if the device resolves the hostname.

Lastly, you can take a look at the configuration example here.

Kind Regards,

I downgrade to ver6 becuase when I was on the latest version7 according to the system firmware check. I don’t have the option to enter the Endpoint Address. The following field are not available.

Has anyone experience that?


You can download firmware from our wiki page here. Select your device and go to firmware downloads. There, you can download the latest firmware and upload it via WebUI. However, if you have a legacy device, it may not be possible to update. Please check the product code of your device.

* FW version RUT9_R_00.07.00 and above will not be supported on legacy-design (RUT955 *7V***) devices.

Regarding the Endpoint address. I was refering to endpoint host. Do you know the IP address of the remote endpoint host?

Kind Regards,

Hi AndzejJ,

I was trying to explain that the latest version firmware doesn’t have the option to enter endpoint address/host. See picture below the comparison between the versions.

this is legacy version


In the upper-right corner of the WebUI, click on ‘Basic’ mode to switch to the advanced mode. You will see more options.

Kind Regards,

Hi AnderjJ,

Thank you for pointing that out. I didn’t notice that. I will try wireguard again on a new firmware version and report back.

Hi AndrejJ,

Thanks for the help. The new firmware and the Advance mode change was what I am missing, did a rough test and it worked.

This topic was automatically closed after 15 days. New replies are no longer allowed.