SDK TRB14X fails to build

The latest SDK for TRB14X (07.07.2) fails to build:

SHELL= flock /home/cst-admin/trb14x_07_07_02/tmp/.libcutils-sdxlemur.tar.xz.flock -c '          (       echo "Checking out files from the git repository..."; mkdir -p /home/cst-admin/trb14x_07_07_02/tmp/dl && cd /home/cst-admin/trb14x_07_07_02/tmp/dl && rm -rf libcutils-sdxlemur && [ \! -d libcutils-sdxlemur ] && (git clone  git@git.teltonika.lt:teltonika/packages/qualcomm/libcutils.git libcutils-sdxlemur || git clone   libcutils-sdxlemur) && (cd libcutils-sdxlemur && git checkout sdxlemur1.0 && git submodule update --init --recursive) && echo "Packing checkout..." && export TAR_TIMESTAMP=`cd libcutils-sdxlemur && git log -1 --format='\''@%ct'\''` && rm -rf libcutils-sdxlemur/.git &&       tar --numeric-owner --owner=0 --group=0 --mode=a-s --sort=name ${TAR_TIMESTAMP:+--mtime="$TAR_TIMESTAMP"} -c libcutils-sdxlemur |       xz -zc -7e > /home/cst-admin/trb14x_07_07_02/tmp/dl/libcutils-sdxlemur.tar.xz && mv /home/cst-admin/trb14x_07_07_02/tmp/dl/libcutils-sdxlemur.tar.xz /home/cst-admin/trb14x_07_07_02/dl/ && rm -rf libcutils-sdxlemur;  )'
Checking out files from the git repository...
Cloning into 'libcutils-sdxlemur'...
ssh: Could not resolve hostname git.teltonika.lt: Name or service not known
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
fatal: repository 'libcutils-sdxlemur' does not exist
make[3]: *** [Makefile:50: /home/cst-admin/trb14x_07_07_02/dl/libcutils-sdxlemur.tar.xz] Error 128
make[3]: Leaving directory '/home/cst-admin/trb14x_07_07_02/package/teltonika/qualcomm/libcutils'
time: package/teltonika/qualcomm/libcutils/compile#0.11#0.06#0.22
    ERROR: package/teltonika/qualcomm/libcutils failed to build.

Can you please fix the SDK that’s online? Especially with the upcoming PCN we need to update our package to the latest FW.

Ping, anyone from Teltonika?

Hi, I have the same problem file missing libcutils-sdxlemur.tar.xz

full error below

fatal: repository 'libcutils-sdxlemur' does not exist
make[3]: *** [Makefile:50: /home/yma/Teltonika/rutos-mdm9x07-trb1-sdk/dl/libcutils-sdxlemur.tar.xz] Error 128
make[3]: Leaving directory '/home/yma/Teltonika/rutos-mdm9x07-trb1-sdk/package/teltonika/qualcomm/libcutils'
time: package/teltonika/qualcomm/libcutils/compile#0.18#0.16#0.31
    ERROR: package/teltonika/qualcomm/libcutils failed to build.
make[2]: *** [package/Makefile:114: package/teltonika/qualcomm/libcutils/compile] Error 1
make[2]: Leaving directory '/home/yma/Teltonika/rutos-mdm9x07-trb1-sdk'
make[1]: *** [package/Makefile:108: /home/yma/Teltonika/rutos-mdm9x07-trb1-sdk/staging_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/yma/Teltonika/rutos-mdm9x07-trb1-sdk'
make: *** [/home/yma/Teltonika/rutos-mdm9x07-trb1-sdk/include/toplevel.mk:234: world] Error 2

Hello,

I was able to reproduce the issue and reported it to our developers.
Thank you for reporting!

Best regards,

1 Like

Hello,

The fix will be included in 07.07.4 RutOS release.
In the meanwhile, the following command can be ran in the root SDK directory to resolve the issue:

sed -i '/PKG_SOURCE_URL/d' package/teltonika/qualcomm/libcutils/Makefile \
      package/teltonika/qualcomm/qmi-framework-vendor/Makefile

Then run the following command to make sure all of the packages are downloaded successfully:

make download

If all goes well, the SDK can be compiled using the regular procedure.

Best regards,

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.