Scanning for operators never finishes

Dear sir/madam,

I have a RUTX50 with latest firmware (7.05.3). When I scan for operators the message “Scanning for operators… it might take up to 180 seconds” is displayed, but never dissapears. I’ve waited for 10 minutes.

I do notice my connection is gone for a little while and comes back about a minute later. However, the webinterface seems to hang.

In my browser console I see this error for https://MY-IP/api/mobile/modems/actions/scan_network
{“success”:false,“errors”:[{“source”:“Authorization”,“code”:121,“error”:“Missing bearer token”}]}

Could that be the reason?

Is there some other way to scan the network and select an operator? Maybe via gsmctl on the command line?

Thank you for your help.

Regards, Jeroen


Try clearing browser’s cache, re-login, and try running the scan again.

Another thing you can try is to set operator selection to manual, enter a randon operator code (so that the device cannot connect to this operator), save & apply, and then try scanning for operators again.

Also, you can use the following command to scan for the operators from the command line:

ubus -t 600 call gsm.modem0 scan_operators

This command may take a while.

Kind Regards,

Hi AndzejJ,

Thanks for your help. Resetting my browser cache did not work, but putting in a random operator code and scanning again DID work. Thanks.

I now have another question. When I select another operator from the list (manual mode) I get the message “Mobile network rejection was recently detected”. When I put the SIM card in my phone, it will connect with this operator without a problem. Do you have a suggestion how to solve this?

Thank you, Jeroen


What are the results of the scan? For instance, does it show that the operator is forbidden?

When you enter your operator’s code manually and save the settings, could you please navigate to Status → Network → Mobile and check what the page says? You can restart the modem on the same page (its possible that the modem will be busy. In this case, just wait a bit and try restarting it again).

Also, did you configure your APN on the mobile interface or are you using Auto-APN? Please, try setting your APN manually in Network → WAN → Edit mob1s1a1 → disable Auto-APN and enter your custom APN (you should be able to check what APN is used in your phone when you use this SIM card).

Kind Regards,

Hi AndzejJ,

Thank you for your help. The scan does not show forbidden for this operator. Also I’ve configured a custom apn and this works well.

I just did another test and now I the connection to this operator is successful (no more messages like “Mobile network rejection was recently detected”). I don’t really understand because I did not change anything, but I am happy. Do you know what the reason could be that the connection to this operator first failed, and now succeeds?

Thanks again, Jeroen


I would assume that the issue is with the modem being busy. The rejection error you encountered might have been caused by entering a random operator number during your first configuration. It should be working properly now. I recommend keeping an eye on the situation to check for any recurring errors or if the device encounters difficulties connecting to the operator in the future.

Kind Regards,

Thank you very much for your help. I will keep an eye on it. Best regards.

This topic was automatically closed after 15 days. New replies are no longer allowed.