RUX11 GPS AVL over Domain to Traccar not working

I’ve been trying to get the AVL stream working over a domain-name for three days.
When the RUX11 is on my LAN and I enter my Traccar server’s LAN IP with port 5027, the AVL stream works fine and the location shows up in Traccar - great.
But when I enter my “example.mydomain.com” with port 5027 or 80 or 443 or… no stream reaches the Traccar server.
I’m using Nginx as a reverse proxy and have also tried HAProxy in pfsense. And of course the Revese proxy works as I use the same address with the Traccar client app on Apple IOS using port 5055 but for Teltronika I changed the port to 5027.
What does the RUX11 send, https or http?
How can I be sure that the stream is also running via the modem?
Is there anything else I can try?
Any hints?
All suggestions are welcome!

Hello,

Can RUTX11 resolve your DDNS hostname?

nslookup example.yourdomain.com

You can install tcpdump and run it on port 5027 to see if RUTX11 sends any data:

opkg update
opkg install tcpdump
tcpdump -i wwan0 port 5027

If you do not see any data, try rebooting RUTX11 and check again.

Kind Regards,

Thank you for your Answer!

root@Teltonika-RUTX11:~# nslookup http://tractower.ddnss.de
Server:         127.0.0.1
Address:        127.0.0.1#53

Name:      http://tractower.ddnss.de
Address 1: 85.114.136.161      <---- this is my DSNS Provider
root@Teltonika-RUTX11:~# traceroute tractower.ddnss.de
traceroute to tractower.ddnss.de (91.96.211.148), 30 hops max, 38 byte packets    <--- my actual IP on WAN
root@Teltonika-RUTX11:~# tcpdump -i wwan0 port 5027
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on wwan0, link-type RAW (Raw IP), capture size 262144 bytes
16:05:31.021801 IP 10.116.164.80.50032 > dyndsl-091-096-211-148.ewe-ip-backbone.de.5027: Flags [P.], seq 2424956570:2424956587, ack 3718978252, win 2003, options [nop,nop,TS val 449027752 ecr 155396763], length 17
16:05:31.090493 IP dyndsl-091-096-211-148.ewe-ip-backbone.de.5027 > 10.116.164.80.50032: Flags [R], seq 3718978252, win 0, length 0
16:05:32.019497 IP 10.116.164.80.50044 > dyndsl-091-096-211-148.ewe-ip-backbone.de.5027: Flags [S], seq 1182146918, win 64240, options [mss 1460,sackOK,TS val 449028750 ecr 0,nop,wscale 5], length 0
16:05:32.085473 IP dyndsl-091-096-211-148.ewe-ip-backbone.de.5027 > 10.116.164.80.50044: Flags [S.], seq 2137462188, ack 1182146919, win 65228, options [mss 1452,nop,wscale 7,sackOK,TS val 3847262723 ecr 449028750], length 0
16:05:32.085716 IP 10.116.164.80.50044 > dyndsl-091-096-211-148.ewe-ip-backbone.de.5027: Flags [.], ack 1, win 2008, options [nop,nop,TS val 449028816 ecr 3847262723], length 0
16:05:32.085978 IP 10.116.164.80.50044 > dyndsl-091-096-211-148.ewe-ip-backbone.de.5027: Flags [P.], seq 1:18, ack 1, win 2008, options [nop,nop,TS val 449028817 ecr 3847262723], length 17

logread:
Fri Sep 15 16:06:54 2023 daemon.info avl[18745]: Error occured while sending IMEI to server, trying to reconnect | err: 32
Fri Sep 15 16:06:54 2023 daemon.info avl[18745]: sock_fd: 7 | IMEI:
Fri Sep 15 16:06:54 2023 daemon.info avl[18745]: [read_imei_output_from_server:76] error: Server doesn't accept module sent data
Fri Sep 15 16:06:54 2023 daemon.info avl[18745]: [avl_loop:295] error: Failed to read imei output from server

I really hope you can find a mistake.
I tried nginx and HAproxy, open a wide open Firewall rule and NAT, but still the same result.

Here I can see in comings in pfsense with the Packet Capture
16:09:14.136698 IP 46.114.244.80.9094 > 91.96.211.148.5027: tcp 17
16:09:14.136716 IP 91.96.211.148.5027 > 46.114.244.80.9094: tcp 0
16:09:14.136766 IP 91.96.211.148.5027 > 46.114.244.80.9094: tcp 187

Hello,

It seems that the server does accept the connection. Also, there are some TCP resets.

Could you please try sending AVL data to your server without a proxy for testing?

Additionally, you can try lowering MTU on your mobile interface in Network → Interfaces → mob1s1a1. You can try 1460,1360,1260, though this is a long shot.

Kind Regards,

Hello Andzej,
you are so kind!
Without the proxy it works. So there must be a config error in the proxy. I’ll investigate further.
Thank you
André

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.