Rutx50 - sim_switch not working

Hello,
I was using a small crontab job for failing over from one sim to another at nights because of the ISP happy hours that one sim has. I have noticed that with the latest firmware( * RUTX_R_00.07.06) update this is not working. Could you please help me to fix this because I need that automatic sim_switch in particular hours.

Kind Regards,
Umut

Hello,

Could you clarify what command you are using to switch SIMs?
Perhaps the Crontab was removed during an update?
I’d suggest using the following command to change to the next available SIM card:

ubus call gsm.modem0 change_sim_slot

Alternatively, you can specify which slot to switch to:

ubus call gsm.modem0 set_sim_slot '{"index":2}' #change to SIM 2
ubus call gsm.modem0 set_sim_slot '{"index":1}' #change to SIM 1

Hope this helps!

Best regards,

Hello,

Thank you for taking time to answer my question. This is the crontab command I used to use to change the active sim to next one.

30 7,0 * * * sim_switch change

I have tried this command to switch active SIM and worked like a charm and edited my crontab job to this.

ubus call gsm.modem0 change_sim_slot

Thank you for your help

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.