RUTX50 regularly loosing connection to modem

I’ve had my RUTX50 since start of July and when it is at home, basically doing nothing, just being connected to 4G/5G it usually takes less than 24 hours and the router has lost the connection to the modem and the 3G/4G/5G LEDs are just flashing. I can connect thru WiFi and login to the admin, but the status page partly times out (the modem status). I can check system- and kernel logs, but the troubleshoot file can’t be generated.

Firmware is RUTX_R_00.07.04.5 with, what it says, the latest modem firmware.

If I power cycle the router it works fine again, so it’s not very likely a hardware issue.

My plan is to use the RUTX50 as secondary WAN when my broadband connection goes down, but currently it’s pretty useless. (I don’t think automatic reboots is a good solution in this case.)

I travelled Europe this summer with the router in my RV, and then the router worked fine, at least after upgrading to RUTX_R_00.07.04.5. “Uptime” was weeks. But when I came home again the problem started again.

In the RV I used a Poynting antenna, but at home the ones included with the router. Same SIM card is used, but when travelling used roaming, so other networks. But then I also constantly used the 4G/5G connection. At home it’s not actively used. Can the modem power down when inactive?

I don’t know where to start troubleshooting…

I tried to attach system.log and kernel.log but wasn’t allowed to, but kernel.log is basically a loop of:

[82630.418363] qmi_wwan 2-1:1.4 wwan0: register ‘qmi_wwan’ at usb-xhci-hcd.0.auto-1, WWAN/QMI device,
[82936.145289] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[82936.145422] option 2-1:1.0: device disconnected
[82936.153218] option1 ttyUSB1: GSM modem (1-port) converter now disconnected from ttyUSB1
[82936.156792] option 2-1:1.1: device disconnected
[82936.166365] option1 ttyUSB2: GSM modem (1-port) converter now disconnected from ttyUSB2
[82936.169232] option 2-1:1.2: device disconnected
[82936.177537] option1 ttyUSB3: GSM modem (1-port) converter now disconnected from ttyUSB3
[82936.181772] option 2-1:1.3: device disconnected
[82936.253884] qmi_wwan 2-1:1.4 wwan0: unregister ‘qmi_wwan’ usb-xhci-hcd.0.auto-1, WWAN/QMI device
[82936.557375] usb 2-1: reset SuperSpeed Gen 1 USB device number 35 using xhci-hcd
[82936.591055] option 2-1:1.0: GSM modem (1-port) converter detected
[82936.591432] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB0
[82936.596710] option 2-1:1.1: GSM modem (1-port) converter detected
[82936.603188] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB3
[82936.609501] option 2-1:1.2: GSM modem (1-port) converter detected
[82936.616093] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB4
[82936.622256] option 2-1:1.3: GSM modem (1-port) converter detected
[82936.629014] usb 2-1: GSM modem (1-port) converter now attached to ttyUSB5
[82936.652766] qmi_wwan 2-1:1.4: cdc-wdm0: USB WDM device
[82936.652994] QMI_WWAN: extending urb size to 31744

system.log is basically an endless list of:

Tue Sep 26 01:33:55 2023 daemon.info gsmd[1645]: [__write:1097] warning: [CMM] Write to 2-1 [2c7c:0800] modem failed: errno 5
Tue Sep 26 01:33:55 2023 daemon.info gsmd[1645]: [common_write_handle:193] warning: [CMM] Failed to send command (0/9 bytes transferred) to 2-1 [2c7c:0800] modem!

Hello,

From the logs it does seem like there is an issue present, but it’s hard to say what could be causing it. Since the issue did not appear while travelling, it’s most likely related to one of these factors:

  • What PSU is used for powering the RUTX50?
    Bad quality or too weak PSUs could cause similar issues. Perhaps you are using a different PSU than what was included in the box?

  • Operator
    We’ve had some issues with certain European operators and their n28 5G band. This required the internal modem firmware to be updated. Could you paste the modem firmware version here so we can double check if it’s the newest?

  • Have you noticed any pattern when this issue appears?
    Perhaps you are downloading a large file, or using a certain application?

The issues with the WebUI are caused by the modem not responding, and the router is trying to recover it, thus the slowness. Let me know the information requested, and we will go from there. Thank you!

Best regards,

Yes, the PSU is different too. In the RV (when it worked) I used your 12V (cigarette lighter) to 4-pin adapter, so it was connected directly to my 12V battery (via fuses and stuff). At home (where the issue is) I’m using your included 100-240V adapter.

At home I’m on the edge of 5G coverage. My iPhone flips between 4G and 5G. When checking the RUTX50 it’s always on 4G, but I can imagine it sometimes connects to 5G instead, and then the problem occurs. I could force it to use 4G and see if the problem goes away. (But I would of course like to use 5G. Otherwise I would have bought a much cheaper router. :slight_smile: My plan is to get a directional 5G antenna for better reception, but want to solve this problem first.)

My operator here in Sweden is Tele2. But I also have a SIM from Telia/Fello that I could try. (When travelled I used both of these, but they were both roaming.)

There is no traffic thru the RUTX50 at all. I just power it up, and lets it sit there without connecting anything to it. Then it “self destructs”.

Firmware version: RUTX_R_00.07.04.5
Firmware build date: 2023-07-24 16:42:15
Internal modem firmware version: RG501QEUAAR12A08M4G_04.200.04.200
Kernel version: 5.4.229

Tried locking the modem to use 4G (LTE) only, but didn’t help. That failed too.
Now trying to lock to 3G. Working so far.

Hello,

Could you try locking the device in 4G + 5G mode, then connecting to it via CLI/SSH, and running the following commands:

opkg update #ignore the errors
opkg install iperf3

iperf3 is a speed testing utility. What I’d like to see, is how your device behaves under high upload conditions. Please run the following command and leave it running for the specified 500 seconds, while monitoring the device behavior:

iperf3 -c speedtest.uztelecom.uz -t 500

This is one of the public iPerf servers (iPerf - Public iPerf3 servers) and is not hosted by us. Please keep in mind, that this test can use up quite a bit of mobile data.
If the device does disconnect, please navigate to System → Administration → Troubleshoot, open the system logs, and copy the logs from the past few minutes. These will hopefully let us determine what the origin of the issue is. If the issue does not replicate during the iperf test, please wait for it to replicate naturally, and gather the logs.
Thank you.

Best regards,

I locked the device to 3G only during the night, and that worked fine (but slow), so yes, possibly some 4G/5G related issue.

I now did your iperf3 test while locking it to 4G+5G (it used 4G during the test), but that didn’t trigger the issue. I currently only have about 5Mbps, so not very high speed, but the problem occurs when I’m not using the device, so speed shouldn’t matter.

But I’ll keep an eye on the router and when it looses connection I’ll post the system.log.

1 Like

Sure, will be awaiting more information. Thank you!

It did now fail with the 3G/4G/5G leds blinking, but this time it went thru a phase of just the 4G blinking. It usually goes directly from “working mode” to fully blinking mode. But anyway, I have a system.log that should be from working state to modem-connection-lost state. But I’m not allowed to upload it with the post, since I’m a “new” user here… How should I send it?

I’ll see if I can get a log for the normal failure too.

Got a new system.log from boot to 3-blink failure. This time, even if the modem is unreachable so no modem status page in the web admin works, the internet connection is up! I can ping 8.8.8.8 and surf the web thru the routers mobile connection. Very odd.

Hello,

Please upload the logs to a third-party hosting service like Google Drive and share the URL here. Do not forget to remove the private information from the logs!

Best regards,

Ok! I have two logfiles in a zip at http://www.ac/teltonika/system_logs.zip. They aren’t the typical failure where it goes directly from “fully working” to “no connection 3G/4G/5G blinking” mode. But they both ended in that 3G/4G/5G blinking mode.

I’m trying to catch a typical failure, but the router has behaved too good during the weekend. :slight_smile:

Hello,

The URL seems to be missing the top-level domain (.com, .net, etc.), could you double-check it?
Thank you!

Best regards,

That is a proper URL. The top-level domain is .ac. Full domain is www.ac. But not sure why the forum doesn’t like it. You might have to copy and paste it.

From the logs it seems like the issue starts when the modem unexpectedly disconnects from the router. The logs do not contain enough information to tell you what the cause is, thus I’d like to investigate the issue further. However, doing so would require us to establish a private channel for communication. If possible, please fill out the Contact Us form here: Teltonika Networks - LTE Routers, Gateways & Modems for IoT and mention this query. Our sales managers should help us get in contact privately.
Thank you for your cooperation!

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.