RUTX50 is a bad choice

Hallo from Germany.
After Years of using a X11 in our Mobil home we decided to upgrade to the “top new” X50. On our last tour I had a feeling of making the badest decision ever.
The RUTX50 stopped working every time we traveled over a boarder and a new roaming Partner came in to connect. Only with power off power on it worked again.
It should calculate the traffic to prevent us going over the limit. But the shown traffic per card was at least 10 times more than our providers calculated. After one day of traveling the RUTX50 show us a usage of 45500 kbytes, but Telekom counted 2,1 Mbyte for the same time. So it is useless, what RUTX50 counts.
Every second or third time the power chance ( RUTX50 is connect to the Board-Battery, like the X11 was), the Router was only blinking and no work in form of routing, only after power off/Power on. Types of changing the power are: Battery use ( 12-13v), connected to land power, so the charging unit starts and power goes up to 14,5v. Disconnecting from Land power and starting the engine, so that the alternator is loading the battery (13,5-14,7v). Every chance is bringing the risc of a crash of the software. Without power chance it worked for days.
The X11 was working like a rock without all these trouble. It never crashed.
And for nearly 6 days I was not able to connect via browser to the router. The connection timed out after giving him my credentials. At day 7 it worked again without problems.
Has anybody the same problems or a solution to fix it?
Greetings from Ostfriesland

1 Like

Welcome. We have a bit of RUTX50 going on this board lately, it seems. There are some bugs that have been discovered, and Teltonika is working on fixing them, we hope, some more or less useful advice proffered and well, a fair bit of complaining. One could start with obvious, just to get it out of the way… a) is everything updated? b) given how I go though data, I can not imagine only 2.1 MB used by anything in a day. I’d guess just pinging the network and all the background stuff will use more. As soon as you open browser it will eat more than 2 MB in a second.

Question: do you get situation where you have 3 SIM-card LEDs flashing and router requiring power cycle to start working again?

1 Like

Hello,

We are sorry to hear that you have had a bad experience with the RUTX50.

  • Roaming issue

It’s hard to say what could be causing the issue without the logs. One workaround could be to setup ping reboot which will reboot the internal modem after the loss of internet connection. This configuration can be found by navigating to Services → Auto Reboot → Ping/Wget Reboot. Google DNS (8.8.8.8) can be left as the IP to check, and as action specify Modem reboot. If this doesn’t help, full router reboot can be chosen.

  • Mobile data consumption

We’ve not had any cases recently, where the mobile data would be over-reported. It could be that the carrier takes some time to update the data, or perhaps some services (e.g. Facebook) are not counted towards the data limit with your mobile plan.

  • Freezing issue

It could be related to a drop in voltage when starting the vehicle. When starting the engine, the voltage can drop significantly. Some tests were performed (source):

The battery voltage mirrors the current during the test. At first it drops to about 4.2V, then recovers to about 8V during the actual cranking. By the time the engine is running it gets up to 10V.

The RUTX11 usually draws less power when compared to the RUTX50, so it may be that the CPU within the RUTX50 locks up due to too low voltage. I would recommend using voltage regulators in this case to avoid undervoltage or overvoltage conditions is vehicles with an internal combustion engines.

And for nearly 6 days I was not able to connect via browser to the router.

Was the RUTX50 restarted during this time? What were the LED indications?

Best regards,

1 Like

On the blinking LED problem. Since last night night I have been again struggling with as well. It’s a strange mode where the router ends up in. I can still remotely reboot it to get it out but after some while it drops back in (no signal leds, blinking 3-4-5G leds). It seems to effect the perfomance somehow but I don’t go off-line and I don’t need a power cycle to get it back. I had it before and it took me almost a full day of trial and error (or run and reboot if you like) to get it back to normal. Very weird behaviour.
The router struggles a lot with connectivity:
image

I was just reading about the option of rebooting or restarting the modem connection. So I wanted to try. Normally I go via overview to the modem and restart. But in this state it seems that the overview screen is not avaliable. Empty… I had that before as well and perhaps related to the same state of the router. There are some firmware issues I would say that are really troublesome/unstable.

Hello, i’m checking in because of my similar experience.
My new RUTX50 is also a disappointment for me. The WebUI freezes constantly, the data connection to the provider drops out several times a day. The reported data volume is absolutely impossible, much too high! The only thing that helps is a hard “power - off - power on” reboot. For one/two hours maybe. I guess its a serious firmware problem and could (should) be solved there.
And, at simcard slot 2 plastic parts fell out, the cards could not be read. I unscrewed it and put it together with glue, it works again now.
I want to love the RUTX50 yes, it is very difficult for me right now!
I also hope for a quick fix!

1 Like

Hi guys,

Good to know being not alone with this issue.

My Rutx50 is installed in my mobile home. To prevent any low voltage issues, I’ve installed the bat120 battery from Teltonika between the camper and Rutx50. The problem still exists.

The workaround to restart modem or reboot by ping request doesn’t work since the whole system is frozen. The reboot request is not carried out.

Hope you guys from Teltonika are able to fix is soon.

If needed I can provide my logs. In my logs I see

  • connection lost
  • internal modem unreachable

—-> system freezes

Best

Robert.

1 Like

Hello,

The issue causing freezing, lost connections, and LED malfunctions, which can only be fixed by power cycling the device, might be due to power issues, specifically voltage drops. Compared to other Teltonika Networks devices, the RUTX50 is generally more powerful. Some users encountered this problem when they replaced their old RUT devices with RUTX50s in their campers and used the same powering options they had. While the RUTX50 worked fine most of the time, they started experiencing the aforementioned issues occasionally. It turned out that the old devices were more tolerant to powering issues because they were less powerful, but the RUTX50 had a trouble with it. To test this, I recommend using the RUTX50 at home with the original power supply that came with the device to see if the issue happens again.

Kind Regards,

Hi guys.
Strange things are happening. I have removed my router from the wall (wall mounted) and mounted it horizontally. For over a week, the WebUI and roaming has been running flawlessly. Just for testing I put it vertical again and the dropouts were back. Now it is horizontal and running. And I am happy but it makes me think…

2 Likes

Wow, a lot of issues with X50.
I had the X50 for two weeks multiple freeze of UI and connection drop out, many short on 4G (may be due to weak signal). On 3G in works fine for few days then it freezes sometimes short, sometime serveral hours. For me this is test phase i need a device that can handle tough environment and ultra stability, speed is not important. It is mounted vertically now, I can test put it horizontal.
As now I don’t want to connect the device to my business, had really high expectations but not impressed so far.

Hello All

I agree with many of these items. I am on latest firmware which at the moment is 7.04.05. I have an issue where I am connected over the 5Ghz Wireless network, the router is connected by CAT 6 or CAT 7 cable to a fibre router and I get 10Mbps download and 300Mbps upload! Playing with the 2.4Ghz wireless connection improves the download to 70Mbps only! Weird. Nothing I do changes this behaviour including changing the TTL on the packets to 65. When it is operating SIM only then it connects to a 4G+ network at 30Mbps with 0.5 for the upload on a -70dbm signal strength. Not the performance I was hoping for or anywhere near close to the 800Mbps I should get from a 5Ghz connection on a router that is connected by cable to a 1.8Gbps fibre box!

I love Teltonika and I want to work this out but if its not fixed soon then I have to buy consumer products from Netgear - not what I want.

Changes to the SIM interfaces are only accepted by the router if I run the Setup Menu another strange behaviour discovered by mistake. I have not once seen 100Mbps plus on this router on download…

Research continues.

Be well.

Hello,

If help is needed with this issue, please create a seperate thread. Thank you.

Best regards,

Roger that. Peace.

Hello fans,
It appears the 5G IMPLEMENTATION can be specific per Region… That means: USA, NL, DE have different implementation profiles than Lithuainia…
So best is to do serious testing before deployment.
BR
rt bosch

…like Implementing 5G protocol over 4G… I became speechless…

Hello,

5G bands mostly differ between the EMEA and the American regions. Currently, RUTX50 is only designed to operate in EMEA region, and the compatible bands are listed here: Band Lock - Teltonika Networks Wiki
As for the 5G implementation, most of the operators currently use 5G NSA (Non-standalone). This means that the operator network uses 4G core infrastructure, and 5G radios. The router has to first connect to the 4G network, and only then can it connect to 5G. This is not specific to Lithuania, and this configuration is used in many parts of the world.
The device also supports 5G SA (standalone) configuration, which is currently available in a few countries. In this operation, the device can connect directly to 5G infrastructure, without the need for 4G. As mentioned, only a few operators have commercial deployments of such networks.
Standalone or non-standalone implementation depends completely on the carrier, and not us.

Since this topic is no longer used for discussing a single issue, I’m closing it. If anyone has any 5G-related issues, please create a seperate thread. Thank you.

Best regards,

1 Like