RUTX50 firmware request

Please reinstate and or add…

What the current “Network Type” is right now, alongside what is available on the mast currently connected to.

Status > Network > Mobile > Network Type Available: Blah Blah Network Type Now: Blah Blah.

Hello,

In the StatusNetworkMobile section, you can check the network type to which your device is currently connected. By default, it connects to the best available network, such as 4G (LTE). However, if you want your device to connect to 3G, 2G, etc., you can navigate to MobileGeneral and under Network type, select your desired option, for example, 3G only.

I hope this helps with your request. Additionally, thank you for suggesting the addition of “Network Type Available” in the status. I will recommend this to our developers, and it might be included in a future update.

Best Regards,

Thank you Marija,

However, my problem is the opposite ways around. Network Type says 5G NSA permanently and never changes to reflect what the actual network type at any moment in time like it used to before firmware 07.07.1

I can have an inactive connection on a single B3 LTE band and the network type stays at 5G NSA even though it isn’t 5G NSA. I think it should say 4G on a single B3 LTE band.

Before the 07.07.1 firmware upgrade:
With one B3 LTE band network type would say 4G
With two B3 LTE bands, network type would say 4G+
With one B3 LTE band and a 5G N1 band network, type would say 5G NSA VoLTE

This doesn’t happen any more after the 07.07.01 firmware upgrade, network type always says 5G NSA VoLTE permanently, never changes to reflect the actual connection type.

Hello,

Could you please confirm if the same issue persists on RUTX_R_00.07.07.2 firmware version? Thank you.

Best Regards,

It does, the same.


07.07.2 please :wink:

Yes asap as my connection is busy for the majority of the day, solar panels and an ASHP sending out data every few seconds and i’m working online too. So yes as soon as i can, i will post an 07.07.2 screenshot.

Here it is, took some getting.

Hello,

Thank you for confirming that you are experiencing the same issue with the latest firmware.

Could you please check in the WebUI under System → Firmware → Update Firmware to see if there is an update available for the internal modem? If there is, could you please try updating it and check if the issue persists?
image

Thank you!

Best Regards,

Hello Marija,

No modem firmware update available.

Thank you for confirming that.

Could you please navigate to Status → System and tell me what Internal modem FW version is shown?

Additionally, please try resetting the device and check if the issue persists. If it does, please execute this command: gsmctl -A 'AT+QENG="servingcell" and share the output here. Thank you!

Best Regards,

Modem firmware version RG501QEUAAR12A08M4G_04.200.04.200

I’ll have to wait until after working hours to reset the router and I’ll have to remind myself how to recreate reconfigure a few things in advance of doing so too.

Thank you for providing modem firmware version.

Here is a wiki page that explains where to download the backup file in WebUI and how to restore your configurations: RUTX50 Maintenance - Teltonika Networks Wiki. This should help you.

Also, please let me know if you have more questions or need further assistance!

Best Regards,

Thank you Marija,

I did a reset using the option to reset settings rather than a factory reset to start with, and the issue persists.

Upgraded to 07.07.3 without saving settings and the issue persists.

I now have a new issue, not sure whether to include it here or start a new thread with it, but it is relevant to this thread because you’ve asked me to run a command in the CLI box and i can’t.

Windows 10 Firefox 127.0.2 error:

Windows 10 Chrome 126.0.6478127 error:

Tried using my android mobile to run the command, and it’s impossible as the phone is forever fighting what i’m trying to type into the box, and after over half an hour i gave in.

Managed to get the CLI box working.

I know that i do have a 5G NSA connection and will now for the rest of the day, until after dark, so i’ll try offering the command again tonight. But here’s the output of it anyway, even though i know i am connected via a 5G band at the moment.

Hello,

I will need some sensitive information from you. I have sent you a form to fill out, and once completed, I will contact you privately. For the ticket ID, please use “6364”. Thank you.

Best Regards,

No problem, i’ll do this on Monday after the weekend now.

I’ll add that since i did a settings reset then an upgrade to firmware version 07.07.3 without saving settings my router has never dropped a 5G band that i’ve noticed so i’ve been unable to check / see if Network Type changes on dropping a 5G band.

With the hot weather i was up and about at 02.30hrs this am and i thought i’d have a look then with no data in or out it still had a 5G band connected.

Hello,

Thank you for the information. I will be waiting for your form.

Best Regards,

This topic was automatically closed after 18 days. New replies are no longer allowed.