RUTX50 disturbing GLONASS receiver

When i switch on RUTX50 my Raymarine AXIOM chart plotter looses GLONASS connection and positioning accuracy drops from 0.7m to 2-5m. (biggest problem is that COG accuracy drops significantly). I tried switching of 2.4GHz and 5GHz Wifi but did not help. Also tried with 3G, 4GLte and 5G but did not help. Moving device helps but i don’t have good place at boat to move it further. Is there something else I should try?

Hello,

One possible solution could be to ground the device. This can be done by attaching a grounding wire to the designated screw on the back of the RUTX50, to the hull of the ship. This should reduce the interference caused by the mobile modem.
Another alternative could be to use UPS, or isolate the RUTX50 or the chart plotter from the rest of the electronics. We offer a UPS called BAT120 which might help here.
Let me know if either of these options help!

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.