RUTX50 - Change IPsec Route to Different Network

Hi,

I had an IPsec VPN working fine until I added an additional WireGuard VPN. I noticed in the route table, that the “Network” for the IPsec VPN changed from “mob1s1a1” to “wireguard”.

How can I change the IPSec VPN back to use the “mob1s1a” network route?

Here’s a reply to the post:


It sounds like the WireGuard VPN might have overridden the default route for your IPsec VPN. To revert the IPsec VPN to use the “mob1s1a” network route, you’ll need to adjust the routing table manually. You can do this by:

  1. Removing the WireGuard VPN route temporarily.
  2. Ensuring the IPsec VPN re-establishes its “mob1s1a” network route.
  3. Re-adding the WireGuard VPN route but specifying metrics or using custom routing rules to prevent it from interfering with the IPsec VPN route.

You might also want to check the configuration files for both VPNs to ensure they are not set to override each other’s routes.

Thanks for the help.

Prior to setting up wireguard, the IPsec VPN is in the “Mob1s1a” network, with the remote IP subnet (192.168.1.0/24) pointing to the IPsec remote gateway WAN Public IP, with metric 0 and Table 220.

There is a route to 0.0.0.0/0 in the “mob1s1a” network that is in route table “main” and metric of 4.

After the Wireguard VPN is setup the IPsec route to 192.168.1.0/24 changes it’s network from “mob1s1a” to the “wireguard” network, still using table 220.

Then an additional 0.0.0.0/0 route is added for the “wireguard” network in table “main” with metric 0.

Why does wireguard move the IPsec route into a different network?

I’m not sure how I can remove the wireguard default route, but I was able to set the wireguard peer route table to 1000 instead of “main” and the IPsec tunnel is working, I’m able to ping a remote endpoint.

I’m a little confused how this should be configured…

And how can I add a static route to the table 220? —When I try to add a static route, it puts it in “main” and there is no option to select the table number.

This topic was automatically closed after 15 days. New replies are no longer allowed.