Rutx11 no GPS Signal

Hi, we have bought 2 years agoRUTX11. The unit has performed perfectly but suddenly there is no GPS signal. I have upgraded to the latest firmware RUTX_R_00.07.05_WEBUI.bin, followed CLI commands based upon a question I found on the forum

  1. I try to put the GPS antenna outside.
  2. After that I try to execute this command via CLI: **gpsctl -ixap and I have an error
    [main:156] error: Failed to get gps position. ERR: Unable to retrieve valid gpsd response: Not found
    3.I have the same with this command: /etc/init.d/gpsd restart and then retry executing gpsctl -ixap
  3. It still not working, I don’t reboot the device

Still no GPS.
I have downloaded a troubleshoot file

How to resolve it?


If you’re certain that the GPS service is enabled in the WebUI, could you try logging into the CLI(username root, password is the same as the WebUI), and running the following command:

cat $(ubus call gsm.modem0 info | jsonfilter -e '@.gps_port')

And check if valid NMEA sentences are being sent from the modem?
The output should look similar to this:

If you don’t see any output with this command, then most likely there is an issue with the antenna/cable, or the internal modem of the device. Do you by any change have a different GPS antenna to test with?
Additionally, make sure that the antenna has a Line of Sight with the sky.

Best regards,

When I execute this command cat $(ubus call gsm.modem0 info | jsonfilter -e ‘@.gps_port’), I have
the output similar like you show in the picture

Why in the webUI, services > GPS >map I have a message “No GPS signal”?

I use Wireshark to visualise NMEA Forwarding in UDP and I don’t see anything?


Could you try checking if all of the needed GNSS options are enabled?
If they are, could you try resetting the device?
Keep in mind, that in the map located in Services → GPS → Map, only the GPS location is shown. NMEA sentences for other constellations are only available via the NMEA forwarding feature.
Also, make sure you can reach the collection server from the RUTX11.

Best regards,


I make a reset factory and it works, I have a GPS position in map (in Services → GPS → Map)
All of commands /etc/init.d/gpsd restart, gpsctl -ixap and cat $(ubus call gsm.modem0 info | jsonfilter -e ‘@.gps_port’) works fine

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.