Rutx11 - Modem Firmware

i have a Problem to update the modem firmware.

i installed the latest Firmware RUTX_R_00.07.04.4

in the webinterface under system/firmware say that the latest firmware is installed, but for the internal modem is a update avilable.

the installed modem firmware is: EG06ELAR04A07M4G

i tried to flash the new modem firmware from the server, but it doesn`t work.

the router is connectet by 4G and normal internet workes fine.

any ideas?

is there a possibility to get the modem firmware as download link?

Best regards

Lars

Good day

Can you please advise on which product code you are making use of on the RUTX11
As we need to identify which modem is being used for the correct update procedure

You can get it by looking into the following

Or by looking into the log file “gsm.log”

Regards
Gage

I have a picture from the Label on the Router, but there is no product code on it.

Where can i see the gsm.log?

Good day Larsre

You can either it get via the Troubleshooting File via
System → Administration → Troubleshoot

Or via the Status page
Status → System

Regards
Gage

Perfect, Thanks Gage.

The Product Code is: Produktcode RUTX1100XXXX

regards Lars

Interesting, I have exactly the same problem with exactly the same product & firmware (RUTX1100XXXX with RUTX_R_00.07.04.3). Can’t update the internal modem firmware.

Good day

I would suggest making use of the FOTA firmware update

This will help and also safest way to update firmware

Also please ensure you are doing this with a wired WAN connection so you don’t lose connection while updating

Regards
Gage

The FOTA service can not be activated, when I request ‘Enable FOTA’ I get a ‘failed’ message every time.

+1 also here same Product version and in need to upgrade modem firmware.

In the old forum I received a PM with a word document but I could never get it as my account was deleted.

Any help is appreciated.
Thanks

Try the ‘update from server’ function again today, they may have fixed it, I got mine to update last night and it now says ‘no update available’. The modem version is now showing as EG06ELAR04A20M4G which appears to be a later version. Be patient it was quite slow to update.

I’m having the same problem with my RUTX12. Modem version is EG06ELAR04A07M4G, website says ‘modem update available’:

I did the update from server twice with a restart in between, it still says ‘update available’. The modem firmware can’t be downloaded from the Teltonika Wiki and FOTA can’t be enabled: (for picture see next post)

So I’m stuck here, assuming this thing isn’t reliable anymore? Product code is RUTX1200XXXX with hardware revision 0303.

“An error occurred: Sorry, new users can only put one embedded media item in a post.”
This is ridiculous. Then take a second post with the second image:

Good day

Have you been making use of alternative WAN connection to ensure the modem can get updated?
As a stable WAN connection is needed

Regards
Gage

I have same issues with my RUTX12. I somehow randomly managed upgrade primary modem, but secondary is impossible.

I did steps like:

  • update device firmware (reboot)
  • update firmware of all modems (failed - no response from UI, after some time I reboot the device)
  • after reboot modems didn’t work
  • update device from file (reboot)
  • update secondary modem - just message it’s gonna happen, but not feedback about progress (no reboot)
  • after few minutes, tried to update primary modem - just message it’s gonna happen, but not feedback about progress (no reboot)
  • after few minutes without feedback, update from file (reboot)
  • now primary modem updated, but secondary is not.
  • I tried to update modem few times (no “primary”/“secondary” option available anymore) with reboot, but no success

sometimes when I refreshed the page, modem update banner was shown, but not always during the modem upgrade.


they said wait till 7.6 update and it will be fixed (my problem was same with rutx11)