RUTX11 FW RUTX_R_00.07.05, cannot login CLI or Shell since firmware update

Rutx11, since firmware update to RUTX_R_00.07.05, can not login to CLI or shell - get message once enter password -
“login: can’t change directory to ‘/user’”

I tried from Putty - login admin, pasword message is “access denied”

Shell is enabled as is CLI in firmware.
Have performed factory reset and reconfigured manually and same message.
Have toggled shell and cli off/apply and on - same
Have created a new user and tried - same.
Have reset password and tried - same.

Has anyone else experienced this or can replicate?
I have just tried re-flashing from file and same issue.


Could you clarify what firmware version you have updated from?
RutOS 7.4 had changes made in the SSH service, where RSA keys were deprecated, thus if you’re trying to login using the old keys, it will not work:

Additionally, the username for SSH is root, and not admin.
If re-generating the keys and using the root username does not help, could you try changing the LAN IP and trying to log in again?

Lastly, if none of these options help, please try factory resetting the device using the bootloader method, as it will fully erase the existing files on the device and re-install the operating system: RUTXxx Firmware via The Bootloader Menu - Teltonika Networks Wiki

Best regards,


Thanks for reply.

I flashed to old version fw and reflashed to current, did a factory reset as suggested and seems to have resolved issue.

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.