RUTX09 FOTA disabled and CLI bad gateway

I have 77 RUTX09s. Since upgrading all to RTX_R_00.07.07.1 I cannot enable FOTA and the CLI interface shows Bad Gateway error. Any ideas on what has gone wrong?

When you say you “cannot enable FOTA”, is the actual FOTA toggle failing or can you not see the FOTA toggle?

Hi Mattk. I can enable FOTA using the toggle but when I save the change I get the error " Failed to edit configuration" and FOTA remains disabled.

Your FOTA config might be corrupted.
You can try to reset it by using SSH and copying the default config with command:

cp /rom/etc/config/rut_fota /etc/config/rut_fota

Hello,

It looks like there might be an issue with the WebUI representation. To verify if FOTA is actually disabled, follow these steps:

  1. Access the device via SSH/CLI and run the following command:

    uci show | grep fota
    

    This command should show that FOTA is disabled.

    2024-05-21-09-47-48-192.168.50.1 (root)

  2. To enable FOTA, run this command:

    uci set rut_fota.config.enabled='1'
    
  3. To confirm that FOTA is enabled, repeat the first command:

    uci show | grep fota
    

    Now, it should show that FOTA is enabled. Additionally, please check the WebUI to confirm that FOTA is enabled there as well.

Kind regards,

Hi Marijus
I ran the commands as you described via the CLI interface in RMS and then I checked the FOTA settings by logging in through Webui. FOTA remained disabled and I could not enable it with the toggle because I got the config error when trying to save the change. This is the results of the CLI commands.

Thanks
Regards
Colin

Hi TeWe
Thanks for the suggestion. I ran the command and it fixed the problem on one modem so I will see how I go with the other 70 modems.
Cheers
Colin

Hello @colin.shackleford ,

We are trying to recreate this particular issue, but all efforts were unsuccessful. Could you tell from which firmware version you upgraded to RTX_R_00.07.07.1 and have you used '“Keep settings” option enabled? Maybe you remember, have you used “Keep settings” in previous firmware upgrades too?

Kind regards,

Hi Marijus
Most of the modems were upgrade from RTX_R_00.07.06.6 with only a few upgraded from RTX_R_00.07.06.10 and I used RMS to do the upgrade in batches of 10 modems. I always use “Keep Settings” as part of the process. Thanks.
Regards
Colin

I tried another suggestion from TeWe and restored the fota config file from the original install files and that worked for one modem so I am going to test that on other modems today.

1 Like

A faced the same problem. I was not able to update the modem firmware for the same reason.
I’ve updated the device FW just a few moments before that.

After SSH to device, I check uci show, then use the default config and then it worked.
I see a difference:
When not working: rut_fota.config=rutfota
When working: rut_fota.config=rut_fota

There is an additional underscore symbol.

BusyBox v1.34.1 (2024-04-29 07:31:19 UTC) built-in shell (ash)

    ____        _    ___  ____
   |  _ \ _   _| |_ / _ \/ ___|
   | |_) | | | | __| | | \___ \
   |  _ <| |_| | |_| |_| |___) |
   |_| \_\\__,_|\__|\___/|____/
------------------------------------
     Teltonika RUTX series 2024
------------------------------------
   Device:     RUTX11
   Kernel:     5.10.210
   Firmware:   RUTX_R_00.07.07.1
   Build:      dde6d53e902
   Build date: 2024-04-30 09:58:39
------------------------------------
root@Teltonika-RUTX11:~# uci show | grep fota
dfota.config=dfota
dfota.config.notify='1'
rut_fota.config=rutfota
rut_fota.config.logfsize='5242880'
rut_fota.config.logfile='/tmp/log.txt'
rut_fota.config.enabled='1'
rut_fota.config.check_after='86400'
rut_fota.config.communication_host='rut.teltonika.lt'
rut_fota.config.communication_port='5000'
rut_fota.config.last_update='1603108409'
rut_fota.config.modem_id='3-1'
rut_fota.config.modem_file_to_download='115897771'
rut_fota.config.connection_state='connected'
rut_fota.config.file_to_download='22615325'
rut_fota.config.date_info='2022-02-25 12:38:37'
rut_fota.config.enable_notif='1'
rut_fota.config.modem_info='Modem_newest'
rut_fota.config.fw_info='N/A'
root@Teltonika-RUTX11:~# cp /rom/etc/config/rut_fota /etc/config/rut_fota
root@Teltonika-RUTX11:~# uci show | grep fota
dfota.config=dfota
rut_fota.config=rut_fota
rut_fota.config.enabled='1'
rut_fota.config.notify='1'
rut_fota.config.communication_host='rut.teltonika.lt'
rut_fota.config.communication_port='5000'
root@Teltonika-RUTX11:~#


Hi Blazej
Thanks for responding. It looks like a typo may have slipped into one of the updates. I have just finished sorting out my 77 modems with most of them requiring a default copy of the fota config file. It took me 3 days.

1 Like

Good to hear you’re fine now mate.
77 boxes is quite a lot… :wink:

Hi, I had the same issue on a TRB245 after updating to TRB2_R_00.07.07.1. Accessing via CLI with the instructions abvove fixed it.

But what remains is if I want to change access control setting (for SSH or CLI) and I save the changes the same message pops up (“Failed to edit configuration”). But the changes get into effect. So it’s not a functional issue, but the message is misleading.

Hi @forster.markus,

The new firmware for the TRB245 is now available. Please try it out as it might resolve the issue you were experiencing.

Best regards,