Rutx08 internal hotspot issue

I’ve configured hotspot with internal landing page so user authenthicate by pap

when I’m trying to login i’ve got js error:

ChilliMD5.js:44 Uncaught TypeError: Cannot read properties of null (reading ‘length’)
at ChilliMD5.fromHex (ChilliMD5.js:44:27)
at ChilliMD5.pap (ChilliMD5.js:52:22)
at form.onsubmit (HotspotLogin.js:100:26)

I guess it because challenge input field is empty.
how can I fix this?

code for landing page form:

  <div class="form-container">
                        <form id="login-form" action="/cgi-bin/hotspot/userpass/login" class="form">
                            <input type="hidden" name="challenge" value="<%=challenge%>">
                            <input type="hidden" name="uamip" value="<%=uamip%>">
                            <input type="hidden" name="uamport" value="<%=uamport%>">
                            <input type="hidden" name="userurl" value="<%=userurl%>">
                            <input type="hidden" name="challenge" value="<%=challenge%>">
                            <div class="form-item">
                                <label for="" class="form-label"><%:Name%>*</label>
                                <input name="username" type="text" class="form-input" placeholder="<%:Username%><%=signup and '/Email'%>" required>
                            <div class="form-item">
                                <label for="" class="form-label"><%:Password%>*</label>
                                <input name="password" type="password" class="form-input" placeholder="<%:Password%>" required>

                            <%- if tos then -%>
                                <div class="checkbox-container">
                                    <input class="dialog-input" name="agreetos" id="agreetos" type="checkbox" value="1" required>
                                    <%:I agree to the %><a target="_blank" href="tos"><%:Terms of Service%></a>
                            <%- end -%>

                            <%- if trial then -%>
                                <div class="checkbox-container mleft"><a id="trial_link" href="#"><%=translatef("Click here %s for trial access", "</a>")%></div>
                            <%- end -%>

                            <button class="form-btn" type="submit"><%:Log In%></button>


Since this issue involves custom code, I’m not sure if we will be of any help here. However, if anyone from our forum has encountered a similar issue, please share the solution!

Best regards,

Looks like ‘(coova-?)chilli’ is used here by Teltonika. The correct config and usage is (almost) black magic. Having done several commercial hotspot systems, using coova-chilli, I must say, you better first of all educate yourself in coova-chilli. Be warned: Steep learning curve.

that’s default page internal landing code. No customization. I’ve got errors with js. I’ve tried to upgrade firmware and every time landing login page code was reseted to default. still not working.

I’m not using anything external, just default components cause this issue. I just want to make it work from the box, without any magic.

I don’t understand why it’s trying to parse challange values in pap functions and crush when I’ve got no challenge in internal landing.

Could you clarify the firmware version used and the device in question? RUTX08 does not have a WiFi module.
Additionally, please try clearing the browser cache to check if this could resolve the issue.

yes, but it has hotspot.

RUTX08 / rutx_r_00.07.04.4

about cache: I’ve tryied several times, also incognito mode.

Hotspot works if trial option without authenthication enabled, but if I’m trying to login as user/password I’ve got js errors

UPD. Fixed issue by setting in /etc/config/chilli
option nochallenge ‘0’

and setting
chilli --challengetimeout=60

after that I’m able to login without errors

This topic was automatically closed after 15 days. New replies are no longer allowed.