Rutt 955 will not connect with my smarty sim

Tried smarty in either slots it locks the router and won’t allow anything Just get a red light flashing and the interface says no sim fitted
Put the smarty sim in my phone it works fine
I have tried vodaphone sim and it works fine in slot 1 or 2
Put vodaphone (into default slot) with the smarty in slot 2 works with vodaphone but as soon as i swap to smarty it just locks the router and i have to turn it off remove the smarty sim.
I tried different combinations all with the same results.
Any help would be appreciated


Previously, there were similar issues encountered when using a damaged SIM card. The strange part is that the same SIM card functions properly when used in your phone. Perhaps you could try inserting the SIM card into other devices to see if the problem persists. Similarly, have you had a chance to test different SIM cards with the RUT955 besides the ones you have already mentioned?

Please, try connecting to the router via CLI/SSH and executing 'logread -f ’ to view logs in real-time. Then, insert the SIM card and check if any interesting messages or error codes appear in the logs that might provide clues about the issue. If you choose to share the logs publicly, make sure to blur or redact any sensitive details that might be present in the logs. This will help to prevent potential security risks.

Kind Regards,