RUT956 Online but not connected to RMS Website


We have a RUT956 deployed on field. It runs a python program constantly.
The thing is it was seen offline on RMS.
We have a Jetson connected to the RUT, with on it to be able to connect remotely.
The thing is we saw the Jetson online on It means that the RUT is connected to the internet. But the RUT was seen offline on RMS.
I tried removing the RUT from RMS and re adding it, but it keeps being as “not activated”.
I also tried to connect by ssh to the RUT, by connecting by SSH to the Jetson from, and I saw that there is no config file “rms_mqtt” inside the directory /etc/config of the RUT.
I am not able to connect to the Web UI of the Teltonika as it is deployed on field.
How could I fix the RMS registering of this RUT ?

Thanks in advance,



Just to clarify, was the RUT956 active on RMS at any point? Or was it not able to connect from the start?
Are you sure that you have at least 1 RMS credit in your account?
Could you make sure that the service for this device is active? This can be done by logging into your RMS account, select the RUT956, and in the Device drop-down menu select Manage services:

Make sure that the Service option is enabled:

If you’d like to apply the credits to this device automatically, enable the Auto Extend feature.

Best regards,

Hello, thank you for your answer.
The RUT956 was active at some point, but after a while we lost it on RMS, despite it was really online.
I have RMS credits in my account, and service option is enabled.

Thank you for the information.
You mentioned, that you have access to the CLI of RUT956, could you post the output of the following command:

ubus call rms get_status

It should show us why the device would not connect to RMS.
Addiotionally, you could try restarting the RMS service by using the following command /etc/init.d/rms_mqtt restart.

Best regards,

I will try to do the ubus command when the Jetson is back online.
I already tried this morning to do the /etc/init.d/rms_mqtt restart, but it got an error, it said something like config file not found …

I precise that I have several RUT956 on field, and for now I only have this problem with one RUT

I’ll be awaiting the information.
Additionally, please also run the following command:


To check if there is enough storage remaining for RMS.

I have “Command failed : Not found” when I entered ubus call rms get_status
Also there should be enough storage, as I enabled USB memory expansion using a 32GB usb stick.


Could you make sure the device is running the latest firmware? Make sure to backup the Python scripts beforehand, as they will be lost if their directory is not added to the /etc/sysupgrade.conf file.

Best regards,

I have done cat /etc/version, I got
it is the lastest firmware for the RUT956, right ?

Is there a way to set up and enable the rms remotely from the CLI ?
Best regards

Also I have observed that I have no config file called rms_mqtt in /etc/config directory, should I add one similar to the ones I have on my others RUT956 ?


Yes, this config file is necessary. Not sure how it could have disappeared, but you should be able to copy this file from the other devices and paste it into this one. You will also need to restart the rms_mqtt service afterward. Let me know if that helps.

Best regards,

Hello, thank you for your answer.
I have put the rms_mqtt file from another RUT956 inside the /etc/config directory of the faulty one.
I have done /etc/init.d/rms_mqtt restart command but nothing changed.
I have observed that inside the rms_mqtt file, there is some files directories :

config rms_mqtt 'rms_mqtt'
	option ca_file '/etc/rms_mqtt/ca.crt'
	option cert_file '/etc/rms_mqtt/client.crt'
	option key_file '/etc/rms_mqtt/client.key'

The thing is when I look for those files in the /etc/rms_mqtt directory, they don’t exist, and I don’t know why.
Instead I have : files, should I rename them ?

Oh I am now able to do

ubus call rms get_status

And I got this output:

        "next_retry": 1696579302,
        "connection_status": 1,
        "error_text": "Device is not registered in RMS. Please login to and add this device to your account device list",
        "error_code": 8,
        "error": 1

Should i unregister my not activated device on rms website and re add it ?

Yes, that would be helpful as re-registering the device can sometimes help with these issues.

Thank you very much for your help, my device has been added to RMS now.
I’m able to log into it by ssh from RMS website.

1 Like

This topic was automatically closed after 15 days. New replies are no longer allowed.