RUT956, Isolated input on MQTT and GET request

HW: RUT956, FW: 7.04.3

(Continued from a thread in old Forum)
Summary of previously thread: Have switched from RUT955 to RUT956, issue is that seems to not be able to access digital input for either “digital input” or “isolated input” through MQTT. Sending request on topic router/get with either message digital1 or digital2, but in either way the reply on topic router/[id]/digital1 (or digital2) is “N/A”.
As debugging, have tried to access same data through GET request. Original stated result of that was that it would always return 0 (more details on that later), no matter state of actual input.
Reply/suggestion: (stored in old forum, so cannot recall 100% but something like…). Show that requesting data with:, and changing state of invertion on web, produces different output of that request. Suggest to reload firmware.

The new part:
Have factory reset device, and seen that it starts on FW 7.04.3
Have enabled Post/Get on Input/Output service. Retry the GET request.
Have found that when I request din2, I get the state of “digital input”. If I invert digital input in UI output from get din2 switches.
Would have expected that “digital input” would effect din1 and “isolated input” would effect din2, just as on mqtt the messages is “digital1” for “digital input” and “digital2” for “isolated input”.
Have tried get request on the entire list “Available IO’s: acl0 adc0 din1 din2 dout1 dout2 iio relay0”, and cannot see that any of those represent state of “isolated input”

And did again install mqtt service, and reproduced that unit would respond with N/A on requesting digital1 or digital2

(Great that old comunity can be accesed again)

I tried suggestion in old thread, and did the same test, still looks to me as though responce on requesting din2 corresponds to “Digital input” and not “Isolated input”, and responce on requesting din1 always return 0.

Hope someone at Teltonika can find the time to comment, as we are running short on 955 units.

And still, preferences is to get the data over mqtt, that seems to not do the trick at all.



INVERSION ON (On “digital input”, and not “isolated input”)

Thanks in advance


We’ve identified the MQTT issue. It will be fixed with the v7.5 release.
As for the pin names, Isolated input is named iio, and all of the names can be found in this section: RUT956 Input/Output - Teltonika Networks Wiki
Sorry for the confusion on the last post.

Best regards,

1 Like

Thanks a lot for the clerification.
As it turns out, did some incorrect assumptions.

And just to be 100% sure
requesting digital2 on mqtt, that is described as “Value of digital input no. 2”, that is same as in ui is called “Isolated input” (and iio in Input/output section).

Can I find a FW release plan some place on wiki? Just to get a hint if I should wait for that, or go with the GET methood. :slight_smile:


There are no concrete release plans for 7.5, thus I would recommend using the HTTP GET method if the issue needs to be resolved soon. The firmware releases can be found here: RUT956 Firmware Downloads - Teltonika Networks Wiki