Rut955 upgrade and downgrade issues

Hi,
I have tried to downgrade the firmware to legacy firmware specified in this pages RUT955 Firmware Downloads - Teltonika Networks Wiki. After several reboot of the router, I could connect again via webui. Then this time, I have tried to upgrade to latest firmware from RUT9_R_00.07.04.3 to RUT9_R_00.07.04.5_WEBUI.bin. After that I saw the upgrading page was running for ever
Then every time that I have tried to open webui, I could see page not found
pagenotFound

I have tried several times to reboot but the issue persist.

Moreover, it is important to specify that we have this issue only with new teltonika routers that we have recently bought. On older batches of Rut955, we have no issues regarding upgrading or downgrading.

It would be great, if you could help me with this!
Best regards,

Hello,

Could you please clarify if you want to downgrade devices or upgrade them?

Have you tried to reinstall the firmware via bootloader method as described here?

Please, try reinstalling the firmware via bootloader using the latest legacy firmware version first. Then, update to the latest firmware via WebUI.

Also, are all of your devices RUT955 or you have some RUT956 devices? If you have RUT956 devices, are you experiencing any issues with those?

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.