RUT955 connection to IoTHub messes up when changing from free to basic tier


We are currently working on a communication system using the Azure IoT package on a RUT955 device with Firmware version 07.04.5. When using thee free tier on Azure IoT hub the communication works without issues but when changing to the basic tier occasionally duplicate data points are being sent (sometimes a second transaction happens always around 1 minute after the first one) and the connection is sometimes lost to devices. The lost connection has happened two times and both was around midnight if that has anything to do with it.
The problem could of course be on the Azure side for some reason but I wanted to check if anyone suspects it could be something on the Teltonika side as well.
Does anyone know if something on the Teltonika device might cause this?



Do you have any logs or graphs to see the issue?

Within the Azure IoT Hub portal, you should be able to find the option to review logs for details. Navigate to the Monitoring section, and look for the Logs tab or something similar. This should allow you to investigate and troubleshoot issues related to connectivity (and other issues). Sometimes it can say if there were issues on the Azure side.

Kind Regards,

Thank you for the reply, this is a graph of the connected devices from Thursday to ;onday. On Thursday 5 devices were installed and then they dropped off one by one until the last one was disconnected on Sunday evening (the new devices on Monday has been added afterwards.)
I have tried diagnosing and looking at the logs but can’t really find anything useful there, no diagnosis can find any issue.

Could the problem have something to do with that a device loses connection and then regains it again somehow? Or if it loses power and it then goes back on, could that affect the connection between the Teltonika device and the IoT Hub?


The devices should stay connected if everything is fine. Connectivity disruptions, as well as reboots, will cause the device to disconnect. Hows connectivity on those devices? Are they using mobile connection? How’s the signal?

From the screenshots, it seems that there is no pattern to those disconnections.

Would it be possible for you to share some of those here?

Also, could you please share your Azure configurations from RUT955? Make sure to hide sensitive information, such as connection strings.

Kind Regards,

Yes of course, here are some screenshots on the configuration on RUT 955.
I have monitored the data to the MQTT broker on the RUT955 device and everything seems to work fine in that connection.

Here is a picture on the broker:

Apparantly the amount if pictures I can send are limited, here is a picture on the diagnostics for connection to Azure IoT Hub:

And finally here is a log query for connection errors:

I have done some tests on a Teltonika device and the system works without problem if the Teltonika device loses connection to the device that communicates to it with mqtt as well as if it loses connection to Internet briefly. However if the Teltonika device unexpectedly loses power (if the power cord is removed, and I suppose if it would lose power some other way) there is problem both with the device it is communicating with (it needs to reestablish the connection) and the connection between the Teltonika device and Azure IoT Hub. The only solution I have found to reestablish communication to Azure is to create a new device in IoT Hub and add that connection string to the Teltonika unit, a solution that is not exactly ideal.


You could try updating the device to the latest firmware version (but will need to disable the ‘keep settings’ option and reconfigure the device because there can be issues when updating from old FW).

In the v7.05+ there were some changes to some related services. In addition to simply updating the device, you can try the following options:

  • Download Azure package, but instead of configuring the package, configure data to server (you can achieve the same results with data to server now). In data to server, add MQTT data input which will connect to the broker on RUT and listen on a specific topic. In the collection settings, use Azure (Azure in cloud solutions needs to be disabled). This way, when a message on that topic is published to the broker on RUT, data to server will forward it to Azure.

    This option would also allow you to send additional data to Azure if needed (as additional data inputs).

  • Also, in the server configuration (collection) for data to server, you can try using a different attestation method. Instead of SAS, you can try using DPS.

However, we do not have any wiki pages/examples for DPS option, so I suggest checking Microsoft’s page here.

Kind Regards,


There was some problems earlier with getting the Azure IoT Hub package to work with the latest firmware but it seems to be fixed now (could also that we used ‘keep settings’ when updating which caused trouble.
I tried it again now and it seems to be working fine with reestablishing a connection to the IoT hub after the Teltonika device has lost and then regained power. I think the other tips with using data to server can also be of great help in the future. Thanks a lot for the help, I really appreciate it.

By the way, you wouldn’t happen to know if cloud-to-device works by using data to server or by some other way on the Teltonika?


Unfortunately, this is currently not available. Such functionality may potentially be added some time in the future, but I cannot guarantee that.

Kind Regards,

All right, thanks again for the help.

This topic was automatically closed after 15 days. New replies are no longer allowed.