RUT950, wireguard tunnels not regaining IP address after LTE connection interruption

I have a bunch of RUT950 routers, running RutOS 7.0[234].X configured with wireguard tunnels to Mikrotik routers within a private APN network.
Default routes are through the wireguard tunnels, the wireguard peers are made reachable by static routes.
Those work fine - when freshly booted.
After a loss of connectivity via LTE the wireguard tunnels come back up, but they do not get their static IP address reconfigured.

They are shown like this when running “ip a s” on the CLI:
13: tnGCS: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 60 qdisc noqueue state UNKNOWN group default qlen 1000

  • link/none*
    14: tnGCP: <POINTOPOINT,NOARP,UP,LOWER_UP> mtu 60 qdisc noqueue state UNKNOWN group default qlen 1000
  • link/none*
    So no IP address…

After running “ifdown”/“ifup” on the wireguard interfaces (tnGCP and tnGCS), they now get an IP address and everything runs fine again (default routes are set correctly and so on).

In my opinion it should never be necessary to manually ifdown/ifup the interfaces.
If wireguard loses connectivity, it makes sense to me to set the interface operationally down.
No sense to me makes to also remove the IP addresses of the wireguard interface (it is a static IP anyway) - especially if you do not reconfigure it when the wireguard interface is set to up again…
It feels like a bug to me, but maybe I configured something wrong?

Any hints or ideas?


Is 'persistent keep alive ’ in Wireguard settings configured? Services → VPN → Wireguard → Edit your instance → Edit peer → Advanced settings. Try setting it to 20, for example.

Also, I believe the issue is with the fact that there are new IP addresses. I suggest you run a Wireguard watchdog via crontab. It is already available and should help in this case, just add the following to the crontab (crontab -e) from the command line:

*/20 * * * * /usr/bin/wireguard_watchdog

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.