RUT950 upload traffic wont work on some devices

Ok, so my RUT950 have stopped working on some devices on upload traffic. I think this issue started after i uploaded the modem firmware since my ping was a bit high during gaming. And i havent found any way to go back to and older firmware on the modem.
My setup is like this: Rut950 with disabled wifi ->Asus router working as a AP for better wifi access → a couple of switches.

Ill list the way this happened and what i found so far.
I couldnt find a friend in a MP session in FS19, and the ping was a bit high on WoW, so i:

  • Decided to upgrade the firmware on the router. didnt work.

  • Upgraded the firmware on the built in modem.*Now i got FS to work online on 2 PC:s

  • Noticed i couldnt use the chromecast, but my phone worked on wifi flawlessly so i reinstalled the Chromecast to the network. didnt work.

  • Started my PS4 to stream there instead, didnt work, connected the cable, didnt work. Connected the PS4 with only a switch directly to the RUT950 (to rule out the Asus AP) didnt work.

  • Couldnt quite wrap my head around it, so i did a broadband test on an old android pad i had, noticed i get download but no upload traffic throu.

  • Found UPNP addon thing in the router, installed that to see if that could help, it didnt work.

  • Went back to an old firmware on the Router, didnt work
    Tried to find any way to go back on the firmware on the modem, couldnt.

  • Installed the new firmware again, tried to get UPNP or portforward to work, letting all throu the firewall to see if that had anything to do with the traffic, it didnt work either.

So now im a bit stuck and this setup is in my cabin, so when i go up my next time i wanna get this working, couse now the camera is not working either.


Since the issue appeared after a firmware update, please, try the following two things:

  • Navigate to Network → Interfaces → edit mob1s1a1 (if SIM slot 1 is used) → Advanced settings and lower the MTU value manually. Values to try are: 1460, 1360, 1260.

  • If this does not help, try restoring the device to factory defaults in System → Backup as there might have been some migration issues.

If this does not help, could you please provide a bit more details about your issue? It would be helpful if you could also provide screenshots of Status → Overview and Status → Network → Mobile pages. Before sharing the screenshots, please blur/hide any sensitive information, such as IMEI, IMSI, ICCID, Public IP addresses, etc.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.