RUT950 No Access to cli / ssh /bin/ash: Exec format error

Starting from today I can’t connect to one of my devices. When I try to connect via ssh the kitty window closes immediatly after connection. The CLI option from the web UI brings:

SSh Acces through RMS is alos not working. It looks like /bin/ash is somewhat corrupted ?

reboot does not solve this issue.

any idea how to proceed (applying the firmware image again should be the last option)

Help is welcome



Indeed, it seems like something is corrupted with the SSH service. However, to mitigate the issue, the only solution I can come up with (reinstall the dropbear service) involves logging in via SSH. Could you clarify if clients like PuTTY or OpenSSH also cannot log into the device?
If that’s the case, I’m afraid factory resetting the device might be the only option here.

Best regards,

Thank you for your feedback.

as I wrote kitty (followup for putty) can’t login too.

I solved the issue with reapplying the same firmware and restored my configuration. Works now but I’m not sure what happend may be there is a leak ?

Nothing like that was documented by our customers or testers, so I doubt that there is a memory leak. My best guess is that it’s something related to the configuration of the device. Let me know if the issue reappears.

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.