RUT950 does not connect to private APN

I have a RUT950 wired connected to an electrical vehicle charger via ethernet cable.

We have tried using a mobile SIM card after factory resetting the modem and everything works fine.
Once we change the SIM card that is data encrypted we are not able to make connection.

Please note we have tried this data encrypted SIM card on the charger are it works fine.

We have made all the necessary changes to both charger and modem to have the same APN but we are still not able to connect via router.
I have seen old posts in which are suggesting to downgrade the firmware version, this router is currently on FW RUT9_R_00.07.06.3

Current settings are:-
MOBILE ----------

Auto APN - Off
APN - Custom
Custom APN - same one that is on the charger (private APN)
authentication type - None
PIN - (empty) card doesn’t have a PIN

RMS settings ------
Connection type - Disable
Hostname - rms.teltonika-networks.com
Port - 15009

Thank you, any help would be much appreciate it!

It seems that the issue has been resolved by simply disabling the DNS rebind protection setting.

Unsure what this setting is for but it now allows sending a receiving packages through an encrypted SIM card!

This topic was automatically closed after 15 days. New replies are no longer allowed.