RUT950 Cant access Public IP address of the router

Hi, i have a RUT950 cellular router and I cannot access its public Ip address. I am trying to set up port forwarding but the Ip address ports just shows filtered when checking to see if they are open. I have enabled remote SSH, HTTP, and HTTPS. And in the firewall, I set the LAN and WAN both to accept all instead of reject, but I still can’t access the public Ip of the router, or the devices that’s connected to the router using their assigned ports. the router is online, and it has internet, but I can’t use its public Ip in my web browser to access the router or any of the port forwards i have set up. Can someone please help me with this?

The IP probably isn’t really “public” and is perhaps behind CGNAT.

Another possibility is that the carrier blocks incoming packets. This is quite common and I have experienced it myself here in the U.S. on Verizon and Tmobile. They do not allow any inbound traffic—no ping, no HTTP, nothing. So everything has to be done via RMS or VPN.

so, IP address on RUT950 WAN interface are the same as reported by, when you check from behind router? In Latvia you must pay additional money for public ip address, be it statical or dynamic. So, if you just obtain “regular” sim card/contract, then you will not get the internet routable ip address.
And when you pay for public ip, then you have no blocks from provider. At least in terms of ssh/http/https/ipsec/ etc. May be as safety net some old Windows SMB ports may be blocked, but not what you mentioned.

I just received a reply from the company.


According to RFC6598, IP address space from to (which includes your is accommodated for the use by internet service providers as a Shared address space.

It means that these addresses are used as private IP addresses inside service providers networks and are not routable over public internet.

Due to this DDNS, port-forwarding, remote SSH, HTTP, and HTTPS will not work and you need to consider other options:

I’ll be contacting Verizon now. Thanks for all the advise