Rut901 Routing/DHCP

My electrician installed a RUT901 router and connected through the LAN ports different Solar devices to it. The router is a wireless client of my main network/router.
On the LAN interface the DHCP service/server is enabled giving ip addresses to the connected clients. I can’t access these devices from my main network as it’s hidden behind the router.

To access these devices I disabled the DHCP service on the LAN interface hoping the connected LAN clients would request the IP address from my main router but nothing happened (they didn’t get any IP at all). Can I configure a RUT901 router to request IP addresses from my main router and allow connections between them?

Hello,

In this case, there are a few options that can be used:

  • If you’d prefer the upstream router to perform all of the routing, then disable the DHCP server on the RUT901, and set a static IP on the LAN interface. Do not forget to specify the default gateway! Since WAN port will not be needed in this configuration, it can be configured to operate as LAN port by following this article: Setting up WAN as LAN - Teltonika Networks Wiki
    Keep in mind, that masquerading may need to be enabled on the LAN zone depending on the client configuration.

  • If you would like to keep the solar devices on a different network, then leave the LAN zone with the default configuration (IP address can be changed, make sure it’s different than the upstream router). Then navigate to Network → Firewall → General settings, and on the WAN zone, set the Input and Forward flags to accept. Masquerading can be disabled as well:

It should be noted, that firewall will be completely bypassed in this case, and no filters will apply. Since masquerading is disabled, source IP address will also not be overwritten.

Best regards,

Hi Daumantas, thank you for your answer.
I’ve tried your suggestion. The devices don’t seem to request an IP from my main router.
My configuration:

Lan interface

Firewall (I tried with and without masquerading)

This topic was automatically closed after 15 days. New replies are no longer allowed.