RUT360 Firmware Update Challenge

Hello, we have updated a bunch of our RUT360 Devices from Firmware Version RUT36X_R_00.07.06.10 to the currently latest RUT36X_R_00.07.07.1.
All updates are managed over RMS.

From 8 Devices we have only one RUT360 Device, which makes us a Problem to update.

We have done the following:

  1. The update was initiated via RMS (via download from Teltonika Server, not File) to the latest Firmware (RUT36X_R_00.07.07.1)

After pushing Set Update Button we got a Error Message that the Firmware is not compatible with this Device

2.As we could not understand why it should be not compatible and because we have done that for all the other RUT360 without any Issue. We have tried in a second step to do it over the Router UI, not over RMS initiated.

Over Router UI themself the Update has startet over download from the Teltoniika Server to the latest latest RUT36X_R_00.07.07.1. But after the update, the GSM Modem did not connect anymore to GSM, Modem was not found ??

  1. We then have rolled back the Firmware to old RUT36X_R_00.07.06.10 Firmware and UI showed us has shown us that a Firmware Update for the Modem needs to done then. Which we made, Modem Firmware Version was then on EG06ELAR04A20M4G ( by the Way same Version as on all other RUT360 after update the Firmware). Router was now working as expected.

  2. We tried again to initiate the Firmware Update to RUT36X_R_00.07.07.1 but we did have the same effect as in Step 2. Firmware done, but Modem did not work.

  3. We rolled back the Firmware then to RUT36X_R_00.07.06.10 and all is working as expected, only Firmware Update to RUT36X_R_00.07.07.1 is not working.

Any Idea, what has been going wrong here ?

Hello,

Could you please try upgrading without keeping the settings? If you don’t want to lose your configurations, I recommend downloading a backup file.

Please let me know how it goes!

Best Regards.

Hello Marija, we did that, because we needed it when we applied again the Version 7.06.10 to get our config back

as stated, it doesn’t want to apply the new firmware as it says, it is not for that device?? One additional info: This rut360 is one of the first we did bought, so it is an older one. If you need the Serial number, please tell me where to send (PM)

Might be worth trying to upgrade via CLI/SSH or Bootloader Menu?

RUT360 Device Recovery Options - Teltonika Networks Wiki

Hello,

If your device has upgraded to RUT36X_R_00.07.06.10, it should definitely upgrade to RUT36X_R_00.07.07.1 firmware too!

As TeWe mentioned, please try to update the firmware via the Bootloader menu and let me know how it goes! Thank you.

Best Regards,

Hi all

We did upgrade the the firmware wia the Bootloader, being connected directly to the Rut. This way it did work. Thanx a lot.
Never the less, we hope that this will not be the procedure in future, as the routers are on different locations all over Europe. So luckily we had someone with the appropriate knowledge next to the rut360, to be able to do that.
In any case, we can close this INC :slight_smile:
Again, a big thanx for your support.
Cheers
Stéfan

Good to hear it finally worked - thanks for the feedback :slight_smile:

I’m glad to hear that it helped!

Please don’t hesitate to ask on this forum if you have any other questions or concerns…

Best Regards,

This topic was automatically closed 40 hours after the last reply. New replies are no longer allowed.