RUT260 - Issues with GET/POST sms_send

I just got a RUT260 to use as a SMS gateway for sending SMS from various services, and it works well, mostly…

I currently have a setup with a web server receiving webhooks and converting the JSON data and forwarding it to the RUT260 via HTTP POST as a properly formatted text string.
This works 100% when using the /cgi-bin/sms_send?number=00xxxxxxxxxx&text=textmessage
where I receive a HTTP 200 with “OK” and I can see the logs from the RUT260 showing:

daemon.debug sms_send: Calling ‘sms_send’ handler
daemon.info gsmd[2371]: SMS was sent to: 00xxxxxxxxxx
kern.info kernel: Sent 1 PDUs to 00xxxxxxxxxx

But, when trying to send to a group, using /cgi-bin/sms_send?group=groupname&text=textmessage
I also receive a HTTP 200 with “OK”, but no SMS are sent, and the logs only show:

daemon.debug sms_send: Calling ‘sms_send’ handler

I cannot for the life of me figure out why it’s not working.
Sending the exact same data, using the same URI, using something like Postman, works every time - just not when it’s coming from my web server.
Could the RUT260 be expecting any particular HTTP headers in conjunction with the “group”, that I’m missing?

I’ve tried it with firmware versions 00.07.06 as well as 00.07.06.3, but there was no difference in how it worked.

Any ideas?

Hello,

I’ve tried using SMS Gateway on 07.06.3 on RUT260, and using the following URL was able to successfully send SMS messages to a group:

http://192.168.26.1/cgi-bin/sms_send?username=[username]&password=[pass]&group=testing&text=testmessage


I noticed, that in your provided URI there is no password field. Was this excluded on purpose, or perhaps it was missed?
If that is not the case, could you try inspecting the request using Wireshark? Additionally, would it be possible to provide the code snippet responsible for making this request?

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.