RUT241 wifi less than half expected speed


I’m getting less than half the expected wifi speed via RUT241.

RUT241 connected through WAN port to Home Router as priority Failover
SIM card installed and active with no credit as secondary Failover

Home Router wifi and LAN Speed Test typically ~ 50Mbps
RUT241wifi Speed Test typically = 10 to 20Mbps
RUT241 LAN Speed Test typically ~ 50Mbps

Have run the Speed Test through various devices with typically the same results. (Laptops, Desk PC and Mobile Phone)
I have not conducted the same test with the SIM as I will be adding credit to it when not at home, but I suspect results will be the same.
I have updated the firmware to RUT2M_R_00.07.04.5 without any change to the results.

Thanks and I hope you can point to something I may have done wrong.



Have you tried changing channel and channel’s width in general 2.4Ghz settings? Also make sure that transmission power is set to maximum.

I would also suggest using some application to check WiFi channels in your environment. For example, WiFi Analyzer here. Try changing the channel to the one that is less congested.

Also, are there many devices connected to RUT241 via WiFi? Keep in mind that RUT241 has only one WiFi antenna, so there is no MIMO.

Kind Regards,


Have tried multiple channels. Currently in channel the WiFi analyzer is showing no traffic/competing signals.

Transmission power is at 100%

Have tested with multiple devices but only with one device connected at a time. Tested at very close range (1 to 2 meters) and up to 10 meters. Result is always half the speed wirelessly. When testing via RUT241 LAN output, the result closely matches the speed I get from the home router.

Surely 10 - 20Mbps wirelessly is well below what I should be getting from a 50Mbps WAN connection?



The RUT241 router is compatible with the 802.11b/g/n wireless standards, but it’s equipped with just one WiFi antenna. As such, even when using the 802.11n standard, which benefits from MIMO technology utilizing multiple antennas, the RUT241 is unable to use this feature. Additionally, various environmental factors could further reduce the achievable speeds.

One potential way to enhance your speed could be through Software Flow Offloading. Could you navigate to Network → Firewall → General settings and check if enabling Software flow offloading provides any improvement?

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.