RUT241 Modbus TCP Client not working send Alarm sms

Hi guys,

I can’t solve the problem with sending Alarm sms in Modbus TCP client. I have RUT241 with newest firmware RUT2M_R_00.07.06.

Modbus device on network is OK, and is possible read values. When i use “Request configuration settings” with “Test” button everything seems good and in functions. But when changing the modbus value (from 0 to 1, or 1 to 0), SMS sending will not be activated. What could be the problem please. Can you direct me please?

Thank a lot for yours help. M.

Hello,

Thanks for reaching us.

Kindly can you provide the configuration for the alarm configuration ?

Ensure that the configuration settings for the SMS sending feature are correctly configured. Double check parameters such as phone numbers

and I would advice you to try to change the condition If you want to trigger the SMS when the Modbus value changes from 0 to 1 or from 1 to 0, you should use the “not equal to” condition. This condition will be true whenever there is any change in the Modbus value, regardless of whether it goes from 0 to 1 or from 1 to 0.

Thanks

Hi Louay,

Thank you for answer.

I think I have everything set up well. I tried change condition as you recommended, but still without any change. I checked the SMS sending via the “Send SMS Meassage” function. The SMS message arrived correctly. I am attaching the “Modbus Alarm Configuration” setting. During the “Test” function in “Request Configuration Testing”, the value of Modbus point changes.

Thank you for your cooperation and guidance to solve my problem.
Best regards. MF




Hi,
Hi, I was testing Modbus communication. For sending SMS Alarms by Modbus was help me changing “Port” of “Modbus device configuration”. From default 502 to e.g. 555. Now SMS notification correctly is in function. Why the RUT241 behaved strangely on port 502, I could not find out.

Thanks a lot.

This topic was automatically closed after 15 days. New replies are no longer allowed.

Hello,

Glad to hear that your issue is solved.

Regarding the Port 502 issue, it could be a port conflict with other devices or servers. So changing the port was an excellent call.

Thanks