RUT241/241 as WiFi client does not have Fast Roaming option

As above, we are trying to configure a RUT 240 as a WiFi client (and tested with another RUT241).
Neither of the devices give the Fast Roaming option in the WiFi settings.
We have tried this with multiple WiFi networks.

Both are on the latest firmware.
Both set to client mode, but the option is just missing from the advanced settings in the WiFi instance settings.

Are there other dependant settings which must be set for it to appear?

I have tried adding it manually in the \etc\config file, but this doesn’t seem to have made a difference.
Thanks in advance

Hello,

You can find it under general Wireless settings in Network → Wireless. Then, press “Edit” next to your desired WiFi network, and it should be in the marked location.

It might not be there for you if you are using an older firmware version. So please update your device to a newer firmware version.

Kind regards,

Marijus

Hi Marijus,

Thanks for the quick response.
Sorry if not clear, this is when the device is in Client mode rather than Access Point mode.

I’m running 7.06.3 firmware which is the latest.

The option is just missing from the Wireless configuration page.
As per RUT240 Wireless - Teltonika Networks Wiki
There is no option under Advanced settings for ‘Enable Fast roaming’ or its own Fast roaming tab.

Do you have any ideas why that might be?

Thanks

Hi,

Fast roaming, also known as 802.11r, is configured for the access point, not for each individual client. You can locate this setting in the access point interface.

By the way, the latest firmware version is 7.06.10. Feel free to give it a try.

Best regards,
Marijus

It seems to say quite clearly on the Wiki that it is also for Client mode and in the changelog.
Please see the below:



It definitely seems to be advertised as a feature for client mode, but we are unable to see it.
I’ve just updated to the 7.06.10 firmware and it appears to still be missing.

Any further assistance would be much appreciated!

Hello,

This was not intended. Thank you for noticing! I already relayed this to the R&D department and they are investigating and working on this issue. This should be fixed in upcoming firmware updates for RUT2 series devices.

Kind regards,
Marijus

This topic was automatically closed after 15 days. New replies are no longer allowed.