RUT240 with Mobile Data Disconnected - Reconnects without consent after power off_on cycle

Refer to this previous topic closed on 2023 Dec 5:
RUT240 with Mobile Data Disconnected - Reconnects without consent after power off_on cycle

Thanks for the UCI command suggestion syntax.
However, I have no idea on how to implement the three lines of UCI commands that you have suggested…

I have read your Modify SMS Rule wiki and your UCI command usage wiki, however, there is no discussion on how to run three (3) lines of UCI commands by sending an SMS text to initiate a UCI API action.

Where and how do I write the UCI command in the RUT240 so that I can call and run it with an SMS message?

RUT240 is Batch no: 099 with firmware version RUT2_R_00.07.04.3

Thanks in advance, Graeme Palmer

Hi,

As per previous topic, you need to run the following uci commands

uci set network.mob1s1a1.disabled='1'
uci commit
/etc/init.d/network restart

SMS utilities have multiple authorization and commands. For example, authorization will be admin router password and SMS command would be reboot. The syntax look like this:
admin01 reboot

With that, the 3 SMS commands restart mobile are:

admin01 uci set network.mob1s1a1.disabled='1'
admin01 uci commit
admin01 reload_config

Let me know if this cleared your doubts.

Regards,

Hi Janmiguel, thanks for your clarification.

I now understand that: one way to disable the data is that I need to send three (3) separate SMS messages in sequence as:
SMS message 1: adminpwd uci set network.mob1s1a1.disabled=‘0’
SMS message 2: adminpwd uci commit
SMS message 3: adminpwd reload_config

I do not wish to openly send these three explicit SMS commands to the RUT240 for all the world to see (and maybe use later)…

Is there a way? to program all three lines of UCI commands into the RUT240 and assign them as a group to one new SMS Rule.
For example new SMS Rule name: xyz
Then execute all three UCI command lines by sending this one SMS message: adminpwd xyz

Kind regards,
Graeme

Hi,

We also have an SMS action which is “Execute a custom script”. Go to Services → Mobile Utilities → SMS Utilities → Add Rule → Action: Execute a custom script → Add.

Then, paste the following codes on the Custom Script tab to restart mobile connection

#!/bin/sh

uci set network.mob1s1a1.disabled='1'
uci commit
/etc/init.d/network restart

sleep 5

uci set network.mob1s1a1.disabled='0'
uci commit
/etc/init.d/network restart

Lastly, Click Save and Apply.

Once you send adminpwd xyz to router’s number, it will disable and enable its mobile interface.

Regards,

Hi Janmiguel, thanks for advice about the SMS action ‘Execute Custom Script’ option.

I have set a script for SMS Rule ‘xyz’ to:

#!/bin/sh
uci set network.mob1s1a1.disabled=1
uci commit
/etc/init.d/network restart

An SMS message to RUT240: ‘adminpwd xyz’ now disables the data OK and data is not enabled when the RUT240 power cycled off/on - thank you !!

I have also set a script for another SMS Rule ‘xyzon’ to:

#!/bin/sh
uci set network.mob1s1a1.disabled=0
uci commit
/etc/init.d/network restart

An SMS message to RUT240: ‘adminpwd xyzon’ now also re-enables the data OK.

However, each time I send SMS message: ‘adminpwd xyz’ or ‘adminpwd xyzon’ I also get an SMS reply from the RUT240 with the following text:

{
?“state”: “OK”
}
Failed to apply configuration for switch ‘switch0’
Status code: 0

What does this RUT240 SMS reply mean? is it important?

How do I disable the SMS replies?
My telecoms service provider charges me for SMS messages sent from the RUT240.

Kind regards, Graeme

Hi,

I have tried it with my device but I got this response:

The SMS is auto-generate.

I would suggest for you to upgrade the device’s FW version. Please refer to this link for the step by step instruction.

Regards,

Hi Janmiguel,

Thanks for your suggestion to upgrade the RUT240 firmware.

I have now upgraded my RUT240 firmware to RUT2_R_00.07.06 of 20231219_201627.
However, still receiving the same ‘auto-generated’ SMS messages back from the RUT240 after I have sent SMS: ‘adminpwd xyz’ or ‘adminpwd xyzon’ - the SMS text received is still as below:

{
?“state”: “OK”
}
Failed to apply configuration for switch ‘switch0’
Status code: 0

Do you have any other suggestions on how to disable these SMS replies from my RUT240?

Kind regards, Graeme

Hi Janmiguel,
Forgot to mention that the SMS messages ‘adminpwd xyz’ or ‘adminpwd xyzon’ when sent to the RUT240 still Disable and Enable the data OK as required.
Kind regards, Graeme

Hi,

SMS response are auto generated to confirm that the new configuration applies. Can you try to insert a Sim that does not have SMS plans?

Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.