RUT240 wifi roaming issue


I am currently using RUT240 as a wireless adapter for an AGV, however I have an issue where the RUT240 gets locked to a certain access point. The firmware version of the RUT240 is RUT2_R_00.07.04.3.
I tried to follow the instruction here for the bgscan, but it does not help:

I also tried to remove the BSSID in my wireless setting, but it even made the RUT240 unable to connect to the infrastructure wifi. The wireless connection is 0% and when I sshed to the router, the wlan0 is not connected to the infrastructure wifi.
Does anyone have a suggestion?

Best regards,
Leonardo Tan

So the robot has 2 wifis, one is to connect to the infrastructure wifi as client and one wifi is to create access point. I somehow get the roaming working by disabling the wireless access point. So after removing the BSSID in the ‘client’ wireless connection and setting up the bgscan now it can switch access point.

I first noticed another problem where the RUT240 can not be found in the infrastructure wifi network after being idle for long period of time. I then connected my laptop to the RUT240 local access point and I found that the connection with the infrastructure wifi also suddenly start working.

This topic was automatically closed after 15 days. New replies are no longer allowed.