RUT240 WebUI dead

I was updating my firmware to on my RUT240 R_00.07.04.5_WEBUI using the WEBUI, my browser reboot due to some issue, I think the updating process was interrupt and crash, after that I can’t access the WEBUI from the browser ,the cellular is still working but very slow, I have tried access via ssh, and it’s able login RutOS, I tried updating (same R_00.07.04.5_WEBUI ) again using the command line ,but it said can’t update to older version, because my Rut240 is setup On a Unmanned Vessel from the manufacturer, I’m afraid of rebooting my rut240 will lost the configuration ,which the manufacturer doesn’t provide ,what is the best way to fix the problem


Thanks for contacting Teltonika Networks’ technical support team.

Since the manufacturer does not provide the configuration, there is a possibility that the device not only has a custom configuration but also custom firmware. This could make the situation a lot more complicated.

Firstly, you could try to restart the uhttpd service. This service is responsible for the WebUI. To do that follow these steps:

Connect to the router via SSH

Execute this command /etc/init.d/uhttpd restart

After executing this command try accessing the WebUI.

If the router uses custom firmware altered by the manufacturer themselves , you should contact them for information about the device. Since we do not know what kind of changes the manufacturer made. In this case, you should contact the manufacturer and try to receive the custom firmware and/or the custom configuration’s backup file.

If the router uses our standard firmware , then you could try to upgrade the firmware to version 7.05.4. This is the latest firmware available for RUT240.

To update the firmware via CLI look at this wiki page for instructions: Firmware upgrade via command line - Teltonika Networks Wiki.

Remember: when you are upgrading the firmware via CLI use flag -o. With this flag, you tell sysupgrade to preserve all the router’s configuration. For example, sysupgrade -o RUT2_R_00.07.05.4_WEBUI.bin

If the problem persists even after upgrading/reinstalling the firmware with preserved settings then there is a chance that there is a problem with the file system and/or configuration files. In this scenario, unfortunately, you would need to perform a firmware upgrade/reinstallation without keeping the settings to return the device to its factory settings to resolve the problem.

Regarding the reboot concern, when a device is performing a firmware upgrade/reinstallation the device automatically reboots.

In most cases, the device should retain its settings after a simple reboot. However, it will lose its settings if you perform a factory reset or if you disable the “Keep settings” option before a firmware upgrade/reinstallation.

The device will lose its settings if you perform a factory reset or upgrade/reinstall the firmware without keeping the settings.

If you have more questions, feel free to ask.

Best regards,


This topic was automatically closed after 15 days. New replies are no longer allowed.