Rut240 flashed to legacy FW, can't upgrade


I was trying to update my firmware as I saw there was a new version, but my RUT240 router didn’t find this on the server.

When I tried it manually, it didn’t work. The files were rejected by the system.

So, I thought to factory reset it. And then the problems started. After the reset, I would get a login screen, would be able to fill in the credentials, but then would be stuck on eternal loading. If I then navigated back to the router IP address, I could see it tried to go to the status page, but nothing would load.

So eventually had to flash the legacy 1.14.7 version on it, which did work!
Unfortunately… I haven’t been able to load any firmware other than the legacy on it.

It’s not that the files get rejected now. But once the new version is flashed, I again get the login page. Can fill in my credentials. But then get the error that the menu items can’t be loaded.

In short: help?
Can you provide me with a solution that doesn’t brick the router?


I assume you were running a rather old firmware version before. Could you access the device via command line (instructions here) and execute the following command?:

hexdump -C /dev/mtd1

If you see many f’s and information about the router is missing, then it is likely that one of the internal files is corrupted. If it is indeed the case, then it should be possible to restore the device. However, in order to resolve the issue that you are currently experiencing, additional provision of further confidential details is required. Due to the public nature of this forum, private communication here is not feasible. Hence, it is recommended that you reach out to your designated sales manager or the reseller from whom you acquired the device in question. They will be able to assist you in addressing this matter more effectively. If this is not feasible, you can fill in the ‘Contact us’ form here.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.