RUT230 wan (eth1) down after update

Hello all,

My first time posting… I hope I don’t do it wrong :stuck_out_tongue:

I got a Teltonika RUT230 from a friend and thought to update it to the latest firmware available.
So on legacy firmware ( RUT2_R_00.07.03.4_WEBUI.bin ) everything works fine. I’m able to plug in a device on the LAN port and have the WAN port connected to my switch itself connected to my internet router and the device is able to ping the greater internet.

As soon as I update to the latest firmware ( RUT2XX_R_00.01.14.7_WEBUI.bin ) WAN port stays in a ‘down’ state.

Now on my switch I can confirm the port is live. I also tried a different cable just in case but of course no help.

I can go back to legacy firmware without touching anything and it works. I also tried a reset (reset pin or factory reset in interface) no go.

So seems pretty odd to me. Kernel/System logs don’t seem to be complaining. If I unplug and plug back in the cable it shows WAN port up on the kernel logs…

Is this a known issue? I was going to use the RUT as a zero tier ‘gateway’ and wanted to make sure I had the latest from the package manager…
Btw I also have RUT200 which works perfectly with the latest firmware

Anyway would love to get to the bottom of this.


are you confusing legacy and latest?

Legacy is
and latest is

Have you tried to factory default your device whilst in the process of upgrading
from legacy to latest (“Keep settings” to off)? That might help. Helped me on
a few occasions.

Timelapse Admin


Sorry if it seemed like I confused legacy and latest. I’ll explain once more

I went from an old legacy firmware version to the latest legacy one (on the website). After doing that everything was working ok.

I then updated to the latest non legacy and everything except the WAN seemed to work.

I did a reset (with the pin method) and also through the interface (Factory reset) and it did not help.

I went back to the latest legacy and it worked again right away.

I just can’t help but think there may be an issue/bug in the latest firmware…

no problem at all.

My suggestion was to upgrade the firmware from the working configuration
on the legacy firmware withe the “Keep Settings” switch set to off, thereby doing
a factory default during the upgrade.

On the other hand if that doesn’t help then you could try to upgrade to the oldest
available non legacy firmware while keeping the settings. Maybe the configuration
doesn’t get converted correctly if you go to the latest non legacy. Just guessing but
could be the solution.

From the oldest non legacy you can try to step up to the latest.

Timelapse Admin

It’s weird though and such a basic thing to test for when putting out a firmware…

This topic was automatically closed after 15 days. New replies are no longer allowed.