RUT X11 AVL Service not running (TOPIC CHANGED)

Afternoon guys

I now realise my previous post was nonsense! but I couldn’t delete it, so editing it instead

It seems that after the upgrade to 00.07.07.3 that 3 things apparently happened

  1. The NMEA server details became populated with the AVL Server settings resulting in a “false positive” situation (NMEA format data being sent to traccar on the wrong port)

  2. After looking at the services screen in the GUI the AVL service was not listed

  3. Logging in via SSH and entering the service status command the AVL Service is in a stopped state and will not run with “service start avl” (which executes but simply returns to the stopped state.

so what do I need to do to debug / resolve this please ?

Many thanks

Regards

BB

OK so a few more bits of information …

When I turn off NMEA (which I have now pointed to 5026) and applied the change , it continues to send data and has been doing so for about 30 minutes

I now can get the AVL service to show as running in CLI but it is not sending any data at all to port 5027 whatsoever

regards

BB

root@[REDACTED]:/usr/sbin# service avl stop
root@[REDACTED]:/usr/sbin# avl
[parse_io_avl_rule:330] error: AVL rule ‘cfg074ab5’ is disabled.
[parse_required_uint:39] error: Option ‘accuracy’ not found for config ‘cfg03b33f’.
[parse_avl_rule_list:394] error: Failed to parse avl rule ‘cfg03b33f’
Segmentation fault
root@[REDACTED] /usr/sbin#

I think its safe to say that the AVL service in 00.07.07.3 is completely screwed up guys!

Regards

BB

00.07.08 has fixed the issue. AVL working normally again.

Regards

BB