Rut 240 - Regular disconnections

Hello all,

I have a RUT240 connected to Vodafone in the UK and we get frequent disconnections which seems to be worse on the latest firmware. RUT2_R_00.07.04.5

Anyone got anything I can check to try and make this a more stable connection. Happy to upload any logs if that will help you diagnose whats going on.

I’m only a little bit techy so please give good instructions!!

Thanks in advance

Hello,

In order to understand the issue better, I will ask you to wait for it to replicate, then navigate to System → Administration → Troubleshoot, open the System Log dialog window, and copy the logs from the timestamp where the disconnection occurred.
Since this is a public forum, I’ll ask you to remove any sensitive information like public IP addresses, MAC addresses, etc. The log contents can either be pasted into a third-party hosting solution and linked here, or simply paste them in your next comment.
I will also ask you to (during normal operation) navigate to System → Network → Mobile and take a screenshot of this window. This will help me identify if the signal strength could also be an issue. Once again, make sure to blur out the IMEI, IMSI, and ICCID values.

Best regards,

Hi Daumantas,

Thanks for trying to help me.

I’ve just had a disconnection while at home so please see the log details below. Have also attached a screenshot of the mobile page. Signal is generally very good as I can see the cell tower directly from the modem’s position. It is roughly half a mile away from us.

I tried posting the log here but it said as a new member I can only post 2 links but not sure I had done any! It’s here on my drop box:

Just happened again as I was trying to send the first message.

Here is a link to the next part of the log:

Just dropped off again for a second time when I tried to do a speed test. Download was fine but the upload fails and I think it has to restart the connection?

Hello,

Indeed, from the logs it seems like while the device is still connected to the carrier, it does not have a connection to the internet, thus the modem reboots to try and recover the connection.
Could you try disabling failover and/or ping reboot and check if the issue replicates?
Additionally, you could navigate to Network → Interfaces → General, edit the mob1s1a1 interface, disable the Auto APN, and insert wap.vodafone.co.uk as a custom APN. This will force the router to skip a few connection checks just so we can validate that there actually is no connection.

If it is confirmed that connection is lost during these short periods, here are a few things to try:

  • Try disabling VoLTE by navigating to Network → Mobile → General settings;

  • Try selecting a different band (e.g. B3) by navigating to Network → Mobile → General settings, selecting LTE-only mode, and only selecting B3 (if it’s available in your area);

Best regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.