RUT 240 - DynDns Public IP not updating

We have setup a new RUT240 and trying to utilize the DynDns service to keep Public IP known. Router firmware is latest available, and IP is Public - 120… - same as other Routers we have setup on our DynDns (not Teltonika). When I manually update Host at DynDns - RUT240 will “Read” value - this is evident in the DynDns Service of the router and Port Forwards etc work as required. We just cant get RUT240 to “Write” /update any changes of IP to the DynDns Host?? - which is needed when the Public IP changes within the RUT240.
I can see this issue or similar has been noted by other users - I just haven’t seen any resolution? - without having to get a SIM with Static IP? - which makes the DynDns service irrelevant and adds ongoing cost!
I look forward to any possible advice to resolve this - Thanks.


Could you please clarify what firmware version is installed on your device?

In the DDNS configurations, there are two fields - check interval, and force interval. The check interval specifies how often the IP address should be checked, while the force interval, how often the IP address updates should be sent to the server. You can hover over those options to see a tooltip:


Would it be possible for you to share some screenshots of your DDNS configurations, as well as the status which is visible on the Services → Dynamic DNS page? Make sure to hide sensitive information, such as IP addresses, etc.

Also, to avoid further confusion for the other users, could you please clarify where you have found the information that DDNS only works with static IP addresses? Thank you!

Kind Regards,

To clarify - If we were to use a SIM with a static IP address, this would eliminate the need to use DDNS.
Firmware = RUT2_R_00.07.04.5
DDNS Status shows running, and Update/ Next Update times correlate with Interval time settings.
Screenshot below show DDNS settings - Hope this identifies an issue with the setup that may help??


Could you please also share a screenshot of the DDNS status in Services → Dynamic DNS?

Do you have a public IP on your mob1s1a1 interface? What are the first two octets of the IP address?

Also, could you try adding a DNS server to your mob1s1a1 interface? To do so, navigate to Network → WAN → edit Mob1s1a1 → Advanced settings. There, add and as the DNS servers.

Are you using any group names within your username?

Do you use the updater client key as a password? You should be able to find this key on the DynDNS website somewhere in the settings.

Kind Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.