Rogue Firmware from Server

One of our RUT955’s updated a new firmware from the server this afternoon. It looks like its really killed the router as we cannot get in via the GUI, and trying command line it will only connect for approx 40 seconds before rebooting.

These are the details with the rogue firmware:

DEVICE: RUT955
Kernel: 5.4.259
Firmware: RUT9_R_00.07.06
Build: e93742651d
Build Date: 2023-12-19 11:53:02

That was pulled from the server.

Please advise urgently

Just checked some of our other RUT955’s that are currently on 07.05.4 and again its saying that a new version is available on the server and points to 07.06 Which has caused us issues on one device we let it upgrade

Be warned

After numerous attempts I have managed to rollback from this rogue firmware by using command line, although had to be quick as it would reboot after a couple of mins.

For anyone who has updated and can get command line, run the following commands:

cd /tmp
wget -c https://firmware.teltonika-networks.com/7.5.4/RUT9/RUT9_R_00.07.05.4_WEBUI.bin

Once it pulls the firmware down, run:
sysupgrade RUT9_R_00.07.05.4_WEBUI.bin

All should be recovered back to previous firmware.

Hello,

Firmware version 7.6 has been released today. During our testing, we did not notice anything similar. Perhaps you could check the upgrade on a device that you have physical access to to see if the issue repliactes? If yes, could you provide the logs from the device when this happens?

Best regards,

RMS was reporting it as bad firmware, on the firmware download site there was no mention of this version.

No matter what I tried I could not get in via the GUI. I have managed to rollback using command line but am dubious about updated 300+ RUT955’s at the moment.

I will need to get out a local test device and test it locally, the other machine I had to depend on remote connectivity.

Still nothing on the WiKi about it:

Hello,

Wiki should be updated soon as well. Please post the logs when possible.

Best regards,

Updated my RUTX50 to this firmware version about 1/2hr ago and at mo not experiencing any issues. But i have noticed a change or two. Exploring those changes.

Just going to try it on a 956 as thats physically with me at the moment, so will update that shortly and see how that goes.

If necessary I can shoot into work and grab a 955

RUT956 Updated to the latest firmware 07.06. On this one I have been able to login to the GUI after its installed, and seems to be behaving itself.

However when you go to CONFIGURE through RMS, it reports “Unsupported Firmware Version”:

image

This was the same with the 955, however on that, I could not login via the GUI, and the device kept rebooting. Command line was the only option, but had to be quick before it rebooted.

I will grab a 955 from the office and give it another go. I am a bit reluctant to try it on a remote router until I feel happy its all fine, and the earlier episode was just a glitch.

Hello,

This should only affect the device configuration and it should be updated shortly.
Just to clarify, on the 956 everything (other than the device configuration via RMS) went smoothly?

Yes thats correct, 956 is all good. Today I will test a 955 to see if I can repeat yesterdays results where it would not allow me to connect via the GUI.

Hello,

For faster and more private communication, could you reach out to us by filling out the Contact Us form here: Teltonika Networks - LTE Routers, Gateways & Modems for IoT
We will be in touch with you shortly after, as our RnD team would like to investigate the issues you’re facing.
Thank you for your cooperation!

EDIT: please add a link to this thread when sending us a message for reference.

Best regards,

Before I fill out the contact sheet, I just wanted to update on testing RUT955 which I have just done at home.

Bear in mind I have good connectivity to it with 4G, although its sat next to me.

System detected the new update and I allowed it to proceed. Once completed RMS showed as back online and I attempted to connect.

I have tried around 7 times but fails to connect every timer witth the following message displayed:

I have done numerous power cycles on it, and still wont let me in via RMS. This is exactly the same results I had yesterday when doing a remote upgrade to 955’s and had to rollback via command line.

What logs do you want?
Do you want me to just grab the “troubleshooting logs”

Hello,

Since this is a public forum, it’s not ideal to share the logs here, as they can contain sensitive information. Please leave the device in the state that it is in currently and fill out the Contact us form with the URL to this thread.
Is the device reachable locally using a direct connection with a LAN cable?
Once the sales managers reach out to you, please attach the troubleshoot file generated via RMS. Thank you.

Best regards,

Will complete details now. I do have access to the device by connecting my laptop.

Many thanks for your help and advice.

This topic was automatically closed after 15 days. New replies are no longer allowed.