Roaming - only connect to certain APs

Hi all,

We are using a RUT240 our robot. It connects to the wifi network of the building and switches between access points on the same SSID.

When taking the elevator on the 1st floor it loses connections once the door close and the elevator start moving. Upon arrival to the 3rd floor, the issue is that it takes it a while to connect to the AP on that floor (same network SSID). We rely on a quick reconnection for our application.

Looking at the logs (logread -f) we can see the modem trying to connect to an AP on the 2nd floor when passing by it when going from 1st to 3rd. We do not need it connecting to this AP as we will never need to go to the 2nd floor. However, my undestanding is that because it is trying to connect to that AP it is still trying to do so when the AP on the 3rd floor gets in range, thus wasting time to connect to the 3rd floor AP.

I was wondering:

  • if there was a way to either blacklist the 2nd floor AP, so that the modem never even tries to connect to it,
  • or to specifiy a list of BSSIDs of APs we do wish to connect to.

Thanks a lot for the help!

Hi,

Welcome to Teltonika Networks Crowd Support!

As of now, we can’t block AP based on BSSIDs. What we can limit is the listening time of the router to AP. Once you created the Wi-Fi Client configuration, click pencil icon → Advanced Settings → enable Fast Roaming.

With this enabled, signal threshold is configured so it will always try to connect to the strongest AP.

Hope this helps!

Regards,

Thanks a lot for the reply!

I have already tried the fast roaming feature, it does not help because the minimum time between 2 background scans is 5seconds and the elevator ride is not much longer.

This is the way my interface in /etc/config/wireless looks when I configure it from the UI and specify a BSSID.

config wifi-iface ‘1’
option ssid ‘name_of_SSID’
option encryption ‘none’
option device ‘radio0’
option mode ‘sta’
option bssid ‘bssid_of_AP’
option network ‘wifi1’
option skip_inactivity_poll ‘0’
option _bgscan_enabled ‘0’
option wds ‘0’
option ieee80211r ‘0’
option disassoc_low_ack ‘1’
option short_preamble ‘1’
option wifi_id ‘wifi1’

What happens if I manually add a second or multiple interfaces with the same SSID but a different BSSID? If that works I would just not create an interface for the AP’s BSSID I do not want to connect to…

REgards

Hi,

Adding multiple interfaces with different BSSIDs would not be possible as 1 Wi-Fi Client can be configured at once, unless Multi-AP is configured. But with Multi-AP, unique SSIDs should be there. If fast roaming is not aiding your solution, may I request for you to try changing configuration like Station inactivity limit, DTIM interval, and listen interval in advanced settings.

Regards,

This topic was automatically closed after 15 days. New replies are no longer allowed.