Reverse DNS not working

I set up a reverse proxy and have external DNS being pointed to my internal IP. So for example, myserver.duckdns.org resolves to 192.168.2.11. This works if I look up that name if I’m external to my network but if I’m behind the teltonika router, it says Name or service not known.

I’ve tested things with a different router, and it works as expected. It seems the Teltonika router is blocking this name from resolving. How can I fix this?

Hello,

By default, Teltonika routers have DNS Rebind protection enabled, which may be causing the issue with your connection behind the Teltonika router. To disable it, follow these steps:

  1. Enable advanced settings.
  2. Navigate to: Network → DNS → Rebind protection → Disable rebind protection.

This should solve your issue, but keep in mind that DNS rebinding is a tricky thing and can be used by attackers to exploit the way web browsers and networks interact. In a nutshell, it lets a malicious website sneakily communicate with devices on your network.

Best regards,

Marijus

This topic was automatically closed after 15 days. New replies are no longer allowed.