QoS/SQM on RUT241

Hi guys,
I’m trying to configure Qos/SQM on RUT241.
But I have problem, after just enabling QoS or SQM (without adding rules) Download/Upload speed on all devices drop below 1Mbps.
Even after I added rule with one IP as source and “all” for destination, protocol and ports and adding second rule with same IP as destination and source, protocol and ports leaving as “all” nothing changed.
Can anyone help me with setting this right?

Firmware: RUT2M_R_00.07.05


When I used QoS in my use case, it is by default on 1024 kbps settings. That is why when you check the speed of your LAN device, it will show around 1 Mbps Upload / Download speed. You can see below some screenshots for references:

1024 kbps Upload/Download

Results in speedtest.net (around 1Mbps speeds)

5120 kbps Upload/Download

Results in speedtest.net (around 5Mbps speeds)

May I know what you are trying to achieve?


Make sure software flow offloading is disabled by navigating to Network → Firewall → General Settings.
Currently, software flow offloading is not compatible with QoS.

Best regards,

Thank you for the fast reply.

I’m trying to prioritize two PCs, rest of the devices are just TVs and smartphones.

I did change the download and upload speeds to match real speeds (D:15Mbps/U:1,4Mbps)
and leave some overhead(D:14Mbps/U:1Mbps)
Even after changing the firewall setting, nothing changed.

Speed test results with QoS:


Could you post screenshot(s) of your configuration of SQM/QoS?
Thank you.

I forget to mention it, but I use WAN port as LAN port.


The interfaces option is used for limiting bandwidth of a specific interface. In your case, you have configured the maximum speed for the LAN interface, meaning the hosts of this network will not be able to achieve speed higher than that. However, the rule is not enabled, so it will not do anything.

The classification rules specify which hosts/protocols/ports should be prioritized. If you’d like two hosts to have priority, you should configure them (as you have done), but you’d also need a rule with Normal priority for the rest of the hosts. The simplest way I could come up with to check whether the priorities are working, would be to run a speed test simultaneously on two hosts - one with Priority target, and another with Normal target. The host with a higher priority should achieve better speeds.

Best regards,

Rule is not enabled because if it is enabled the Internet is unusable slow.

I did test with added rule (with enabled rule) with normal priority and everything else set as “all” and it didn’t change anything.
I tested it exactly how you said before posting here.

Can you please tell me how to set up QoS step by step, I honestly don’t know what I’m going wrong.

By the way,
I did try turning QoS off and enabling SQM (did try just piece_of_cake as is in the wiki) and achieve same result.

This topic was automatically closed after 15 days. New replies are no longer allowed.