Problem with SNAT (Source Nat)

Hi everyone,

I’ve got a problem on teltonika RUTX09.
I explain my configuration.

My interfaces :

  • WAN : Fiber in PPPoE with the private IP 172.16.5.1
    On the operator side, I configure routing 130.93.X.X/30 on this same fiber Interface so now, I just need to source NAT the trafic from my LAN to WAN with the public IP 130.93.X.X inside this public block IP.

But when I select lan as source zone, the trafic from an interface named “Presta” was also source nat with this rule even if this interface was not in this zone LAN.
I create another zone named “Presta” with my interface “Presta” inside only and in Lan zone, there is only “Lan” interface.
But problem was the same, source nat was not correct…
When I filter the source nat with the subnet 192.168.1.0/24, no internet in the lan…

Please find a zip file with pictures, the forum allow only one picture by post…
[redacted]

Thanks a lot !

Hello,

Upon checking the screenshoted SNAT rule, the source IP will be rewritten to 130.93.X.X38. However, your IP in the Presta Interface has 130.93.X.X33. Kindly configure the SNAT to the proper IP address.

At the same time, regarding the firewall zones. Since you’ve created a new interface named ‘Presta’ in the WAN page of the router, this interface will be covered in the WAN zone. For this, try removing the Presta interface in the covered networks of the WAN zone,




then put it on the covered networks of the Presta Firewall zone.

Note that if modifying the SNAT rules above fixed the issue, then no need to play with the firewall zones (as my suggestion only :sweat_smile:)

Hope this helps.

Best regards,
Robert

Thanks for your answer !
I know this but there is a really bug with teltonika firmware and the source zone input.
My Presta zone is not in the WAN Zone but only in Presta Zone, I already check it before open ticket.

The only solution I found to bypass this bug is to create a rule with this settings.
snat-rule

It’s deny the presta host in 130.93.89.234 to be SNAT

This topic was automatically closed after 16 days. New replies are no longer allowed.